PowerStore: NDU Pre-upgradestatuscontrole geeft aan "Kan niet uitvoeren van healthcheckstatus van NAS-subsysteem voorafgaand aan upgrade"
Summary: NDU Pre-upgrade healthcheck mislukt bij het controleren van de status van het NAS-subsysteem.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Foutcode:
0xE0403001000C Foutmelding: Kan de status van de pre-upgrade healthcheck-status van het NAS-subsysteem niet uitvoeren.
0xE0403001000C Foutmelding: Kan de status van de pre-upgrade healthcheck-status van het NAS-subsysteem niet uitvoeren.
Cause
Wanneer een PowerStore T-apparaat het NAS-subsysteem uitvoert, worden aanvullende NAS-healthchecks uitgevoerd tijdens de stappen van de NDU pre-upgrade healthcheck (PUHC).
Als een van de NAS-healthchecks de status van minder dan 4 (4=Goed) laat zien, mislukt de algehele healthcheck voor de upgrade.
Taakdetails van de pre-upgrade healthcheck kunnen meer dan één item "Failed" weergeven. Controleer elk "Failed" item door deze te selecteren en de details weer te geven:
Als een van de NAS-healthchecks de status van minder dan 4 (4=Goed) laat zien, mislukt de algehele healthcheck voor de upgrade.
Taakdetails van de pre-upgrade healthcheck kunnen meer dan één item "Failed" weergeven. Controleer elk "Failed" item door deze te selecteren en de details weer te geven:
Taakgegevens:
Beschrijving
Healthcheck voor upgrade X mislukt
Pre-upgrade healthcheck mislukt op knooppunt A. Bekijk de stappen voor de healthcheck voor meer informatie (0xE0403001000C)
Health check - node A X Failed
Kan de status van de pre-upgrade healthcheck van het NAS-subsysteem niet uitvoeren. Please check the alerts and events page for possible NAS errors and take corrective actions. (bsc_sdnas_puhc_executeStatusApi_error)
Resolution
De taakgegevens in het gedeelte Oorzaak bieden mogelijk onvoldoende aanwijzingen om te bepalen welke NAS-healthcheck de fout heeft veroorzaakt.
Opmerking: Wanneer u bent aangemeld als de servicegebruiker, bevindt u zich in de directory /home/service/user.
In het bovenstaande voorbeeld was een van de opgegeven DNS-servers niet toegankelijk. De NDU-healthcheck slaagt nadat deze toestand is gecorrigeerd.
- Om de oorzaak van de storing te achterhalen, opent u een SSH-sessie naar uw Cluster IP-adres en meldt u zich aan als de servicegebruiker. Zorg ervoor dat u beide knooppunten controleert, aangezien de bestanden op een van beide kunnen bestaan.
- Gebruik de UNIX-tool 'cat' om de volgende bestanden te bekijken, die meer details geven over het NAS-probleem. U moet het volledige pad naar het bestand gebruiken om de inhoud te zien.
Opmerking: Wanneer u bent aangemeld als de servicegebruiker, bevindt u zich in de directory /home/service/user.
/home/service/user
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/123.221.xxx.xxx_sdnas_deploy_error.json
{
"128.221.xxx.xxx":
{ "error_code": "\"1131\"",
"error_description": "\"Health status of the cluster is not 4, cluster is not in a healthy state.\"",
"error_recommended_action": Kijk voor het PowerStore platform naar het bestand /var/log/sdnas/ansible/nas_health_events.log voor meer informatie over de statusgebeurtenissen. Please contact support for further assistance.\"",
"failed_task": "Fail with a message if the health status of the cluster not 4",
"Date/Time": "2020-03-17/17:10:13",
"failed_command": "",
"failed_command_rc": "",
"failed_command_stderr": "FOUT! The health status of cluster is 3. Het cluster heeft niet de vereiste status van 4",
"failed_command_stdout": "",
"failed_node": "128.221.xxx.xxx"
}
}
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/nas_health_events.log
Cluster health status=3
Event ID=5e71040c-0324-32ae-d4e4-56cb091ae676
Event fullDescription=De DNS-client kan geen verbinding maken met een deel van de geconfigureerde DNS-server, maar is nog wel operationeel.\n Dit kan gebeuren wanneer de NAS-server de peer-DNS-server niet kan bereiken vanwege netwerkproblemen.
Aanbevolen actie=Controleer de netwerkinterface van de NAS-server en de routerconfiguratie.\n Of controleer de beschikbaarheid van de geconfigureerde DNS-server door de opdracht 'svc_cifssupport -checkup' of 'svc_nas -dns' uit te voeren.
Name=nasServer
Value=smb160
Event ID=5e710453-d4f8-4239-8b8e-5a3c89700de4
Event fullDescription=De DNS-client kan geen verbinding maken met een deel van de geconfigureerde DNS-server, maar is nog wel operationeel.\n Dit kan gebeuren wanneer de NAS-server de peer DNS-server niet kan bereiken vanwege netwerkproblemen.
Aanbevolen actie=Controleer de netwerkinterface van de NAS-server en de routerconfiguratie.\n Of controleer de beschikbaarheid van de geconfigureerde DNS-server door de opdracht 'svc_cifssupport -checkup' of 'svc_nas -dns' uit te voeren.
name=nasServer
Value=smb161
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/123.221.xxx.xxx_sdnas_deploy_error.json
{
"128.221.xxx.xxx":
{ "error_code": "\"1131\"",
"error_description": "\"Health status of the cluster is not 4, cluster is not in a healthy state.\"",
"error_recommended_action": Kijk voor het PowerStore platform naar het bestand /var/log/sdnas/ansible/nas_health_events.log voor meer informatie over de statusgebeurtenissen. Please contact support for further assistance.\"",
"failed_task": "Fail with a message if the health status of the cluster not 4",
"Date/Time": "2020-03-17/17:10:13",
"failed_command": "",
"failed_command_rc": "",
"failed_command_stderr": "FOUT! The health status of cluster is 3. Het cluster heeft niet de vereiste status van 4",
"failed_command_stdout": "",
"failed_node": "128.221.xxx.xxx"
}
}
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/nas_health_events.log
Cluster health status=3
Event ID=5e71040c-0324-32ae-d4e4-56cb091ae676
Event fullDescription=De DNS-client kan geen verbinding maken met een deel van de geconfigureerde DNS-server, maar is nog wel operationeel.\n Dit kan gebeuren wanneer de NAS-server de peer-DNS-server niet kan bereiken vanwege netwerkproblemen.
Aanbevolen actie=Controleer de netwerkinterface van de NAS-server en de routerconfiguratie.\n Of controleer de beschikbaarheid van de geconfigureerde DNS-server door de opdracht 'svc_cifssupport -checkup' of 'svc_nas -dns' uit te voeren.
Name=nasServer
Value=smb160
Event ID=5e710453-d4f8-4239-8b8e-5a3c89700de4
Event fullDescription=De DNS-client kan geen verbinding maken met een deel van de geconfigureerde DNS-server, maar is nog wel operationeel.\n Dit kan gebeuren wanneer de NAS-server de peer DNS-server niet kan bereiken vanwege netwerkproblemen.
Aanbevolen actie=Controleer de netwerkinterface van de NAS-server en de routerconfiguratie.\n Of controleer de beschikbaarheid van de geconfigureerde DNS-server door de opdracht 'svc_cifssupport -checkup' of 'svc_nas -dns' uit te voeren.
name=nasServer
Value=smb161
In het bovenstaande voorbeeld was een van de opgegeven DNS-servers niet toegankelijk. De NDU-healthcheck slaagt nadat deze toestand is gecorrigeerd.
U kunt ook de scripts svc_nas_tools en svc_nas_cifssupport gebruiken om SDNAS te verifiëren in een poging het probleem te vinden. Zie de Dell EMC PowerStore handleiding voor servicescripts voor meer informatie over de servicescripts.
Voorbeeld van het controleren van de DNS-connectiviteit:
[SVC:service@xxxxxx-B user]$ svc_nas_tools --server nas121 --args="-dns" nas121 : commands processed: 1 output is complete 1597753629: LIB: 6: DNS is running. 1597753629: LIB: 6: DNS active config: override 1597753629: LIB: 6: * VDM Config: global 1597753629: LIB: 6: abc123.lab.emc.com 1597753629: LIB: 6: proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx 1597753629: LIB: 6: * VDM Config: local 1597753629: LIB: 6: abc123.lab.emc.com 1597753629: LIB: 6: proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx 1597753629: LIB: 6: * VDM Config: override 1597753629: LIB: 6: abc123.lab.emc.com 1597753629: LIB: 6: proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx 1597753629: LIB: 6: Dynamic DNS update exclude subnets: 1597753629: LIB: 6: No subnet
Affected Products
PowerStore, PowerStore 1000T, PowerStore 3000T, PowerStore 5000T, PowerStore 7000T, PowerStore 9000TArticle Properties
Article Number: 000133035
Article Type: Solution
Last Modified: 06 Aug 2025
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.