PowerStore: NDU 업그레이드 전 상태 점검에서 "NAS 하위 시스템의 업그레이드 전 상태 점검 실행 실패"가 표시됨

Summary: NAS 하위 시스템의 상태를 확인할 때 NDU 업그레이드 전 상태 점검이 실패합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Error code:
0xE0403001000C 오류 메시지: NAS 하위 시스템의 업그레이드 전 상태 점검을 실행하지 못했습니다.

Cause

PowerStore T 어플라이언스가 NAS 서브시스템을 실행 중인 경우 NDU PUHC(Pre-Upgrade Health Check) 단계 중에 추가 NAS 상태 점검이 수행됩니다.

NAS 상태 점검 중 하나라도 4 미만(4=양호)으로 표시되면 업그레이드에 대한 전체 상태 점검이 실패합니다.

업그레이드 전 상태 점검의 작업 세부 정보에 "실패" 항목이 두 개 이상 표시될 수 있습니다. 세부 정보를 강조 표시하고 확인하여 각 "Failed" 줄을 확인합니다.      
작업 세부 정보:
설명
업그레이드 전 상태 점검 X 실패
노드 A에서 업그레이드 전 상태 점검에 실패했습니다.   자세한 내용은 상태 점검 단계를 검토하십시오(0xE0403001000C).
상태 점검 - 노드 A                                      X 실패
NAS 하위 시스템의 업그레이드 전 상태 점검을 실행하지 못했습니다. 알림 및 이벤트 페이지에서 가능한 NAS 오류를 확인하고 적절한 조치를 취하십시오. (bsc_sdnas_puhc_executeStatusApi_error)

Resolution

원인 섹션에 설명된 작업 세부 정보에서는 어떤 NAS 상태 점검에서 장애가 발생했는지 확인하는 데 충분한 단서를 제공하지 않을 수 있습니다.
  1. 실패의 원인을 확인하려면 클러스터 IP 주소에 대한 SSH 세션을 열고 서비스 사용자로 로그인합니다. 파일이 둘 중 하나에 있을 수 있으므로 두 노드를 모두 확인해야 합니다.
  2. UNIX 툴 'cat'을 사용하여 NAS 문제에 대한 자세한 내용을 제공하는 다음 파일을 봅니다. 내용을 보려면 파일의 전체 경로를 사용해야 합니다.
SLN320669_en_US__1icon 참고:  서비스 사용자로 로그인하면 /home/service/user 디렉토리가 표시됩니다.

 

/home/서비스/사용자
[SVC:service@xxxxxxx-A 사용자]$ cat /var/log/sdnas/ansible/123.221.xxx.xxx_sdnas_deploy_error.json
{
"128.221.xxx.xxx":
{ "error_code": "\"1131\"",
"error_description": "\"클러스터의 상태가 4가 아닙니다. 클러스터가 정상 상태가 아닙니다.\"",
"error_recommended_action": "\"PowerStore 플랫폼의 경우 /var/log/sdnas/ansible/nas_health_events.log 파일에서 상태 이벤트에 대한 자세한 내용을 확인하십시오. 추가 지원이 필요한 경우 지원 부서에 문의하십시오.\"",
"failed_task": "클러스터의 상태가 4가 아닌 경우 메시지 표시 실패", "날짜/시간":
"2020-03-17/17:10:13",
"failed_command": "",
"failed_command_rc": "",
"failed_command_stderr": "ERROR! The health status of cluster is 3. 클러스터에 필요한 상태인 4",
"failed_command_stdout"가 없습니다. "",
"failed_node": "128.221.xxx.xxx"
}



}
[SVC:service@xxxxxxx-A user]$ cat /var/log/sdnas/ansible/nas_health_events.log
클러스터 상태=3
이벤트 ID=5e71040c-0324-32ae-d4e4-56cb091ae676
이벤트 fullDescription=DNS 클라이언트가 구성된 일부 DNS 서버에 연결할 수 없지만 여전히 작동합니다.\n 네트워크 문제 때문에 NAS 서버가 피어 DNS 서버에 연결할 수 없을 때 이 오류가 발생할 수 있습니다.
 Event recommendedAction=Check the NAS server network interface and the router configuration.\n Or check the availability of the configured DNS server running the 'svc_cifssupport -checkup' or 'svc_nas -dns' command.
   Name=nasServer
Value=smb160
Event ID=5e710453-d4f8-4239-8b8e-5a3c89700de4
Event fullDescription=DNS 클라이언트가 구성된 DNS 서버 중 일부에 연결할 수 없지만 여전히 작동합니다.\n 네트워크 문제 때문에 NAS 서버가 피어 DNS 서버에 연결할 수 없을 때 이 오류가 발생할 수 있습니다.
 Event recommendedAction=Check the NAS server network interface and the router configuration.\n Or check the availability of the configured DNS server running the 'svc_cifssupport -checkup' or 'svc_nas -dns' command.
   이름=nasServer
값=smb161

위의 예에서 정의된 DNS 서버 중 하나에 액세스하지 못했습니다. 해당 상태를 수정한 후 NDU 상태 점검이 통과되었습니다.
 


스크립트 svc_nas_toolssvc_nas_cifssupport를 사용하여 SDNAS를 확인하여 문제를 찾을 수도 있습니다. 서비스 스크립트에 대한 자세한 내용은 Dell EMC PowerStore 서비스 스크립트 가이드를 참조하십시오.

DNS 연결을 확인하는 예:       

[SVC:service@xxxxxx-B user]$ svc_nas_tools --server nas121 --args="-dns"
nas121 : commands processed: 1
output is complete

1597753629: LIB: 6: DNS is running.
1597753629: LIB: 6: DNS active config: override
1597753629: LIB: 6: * VDM Config: global
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: * VDM Config: local
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: * VDM Config: override
1597753629: LIB: 6: abc123.lab.emc.com
1597753629: LIB: 6:   proto:udp server(s): 10.241.xxx.xxx, 10.241.xxx.xxx
1597753629: LIB: 6: Dynamic DNS update exclude subnets:
1597753629: LIB: 6:   No subnet

Affected Products

PowerStore, PowerStore 1000T, PowerStore 3000T, PowerStore 5000T, PowerStore 7000T, PowerStore 9000T
Article Properties
Article Number: 000133035
Article Type: Solution
Last Modified: 06 Aug 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.