Avamar:备份失败,无数据状态 - 无法确定插件版本
Summary: 备份失败,并显示“无数据”状态 — Avagent 报告“无法确定插件版本”。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
计划备份或从“策略”窗口启动的备份会立即失败,并显示“无数据”状态。
- 将鼠标悬停在状态上会显示“活动失败 — 客户端没有数据集指定的数据”
- 在“活动报告”选项卡上,它显示为:
- Status_code“30915”,status_code_summary“活动失败 — 客户端没有数据集指定的数据”
- 在“Activities - Failed”报告中,它显示为:
- 状态“30915:活动失败 — 客户端没有数据集指定的数据”
Cause
有几种原因可能会导致此错误。
- 对于下面未列出的错误,请参阅解决方案路径,了解其他原因和解决方案。
- 如果这是 AVE 或单节点锁定为仅将备份指向 Data Domain,则这是预期行为。
- Avamar-DataDomain 集成:如何在单节点中将所有 Avamar 和 Avamar Virtual Edition 备份锁定到 Data Domain 后端。
- 请注意,在“Server”列中,它应显示 DD-server-name
- 使用备份、还原和管理窗口中的备份选项卡验证客户端可访问性。
- 如果插件可见且可浏览,请参阅解决方案路径。
- 如果插件不可见,并且出现一个窗口,指出“此客户端的配置不支持浏览”或“未找到客户端 xxxxx 的插件”。然后,必须检查客户端计算机上的avagent.log。
- 默认情况下,avagent.log位于 C:\Program Files\avs\var 中。
- Avamar 网格上的管理控制台服务器 (MCS) 或客户端计算机本身正在禁用插件程序。
- 如果 MCS 禁用了插件程序,请参阅解决路径以了解相应的解决方案。
- 如果客户端计算机本身禁用插件程序,则日志会记录如下错误。
- 请注意,在“Server”列中,它应显示 DD-server-name
- Avamar-DataDomain 集成:如何在单节点中将所有 Avamar 和 Avamar Virtual Edition 备份锁定到 Data Domain 后端。
avagent Error <5451>: Failed to get plugin 'Windows' version with code 0xc0000142: No error description string
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
- 或者
avagent Error <5451>: Failed to get plugin 'Windows' version with code 128: There are no child processes to wait for
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
- 或者
avagent Error <5451>: Failed to get plugin 'Windows' version with code 255: The extended attributes are inconsistent
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
对于计算机上安装的所有插件(“Windows VSS”、更新、SQL 等),这些错误都会重复出现。
日志报告(具体取决于已安装的 Avamar Client 的版本):
avagent Warning <7145>: No pin files found
- 或者
avagent Warning <7184>: No pin files found
在 Windows 事件查看器中,打开 系统日志 并查找 事件 ID 243 ,例如:
Log Name: System
Source: Win32k
Date: 4/24/2014 10:54:54 AM
Event ID: 243
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: Workstation.emc.com
Description:
A desktop heap allocation failed.
桌面堆是使用本地系统帐户的所有应用程序的共享内存存储空间。如果在事件查看器的系统日志中看到“桌面堆分配”失败消息,则可能是由于内存泄漏。即使 RAM 利用率较低,客户端上的应用程序也可能使用分配给桌面堆的所有内存,从而导致此问题。
发生这种情况时,备份将继续失败并显示相同的错误,直至执行重新启动。重新启动后,备份将再次正常工作几天,然后再次开始失败。再次重新启动可将该问题再解决几天。
提醒: 如果插件程序在初始客户端激活期间无法注册,防病毒软件也可能导致此问题。
某些防病毒软件(如 Symantec)可能配置了高度安全和/或严格的扫描设置,这会阻止注册 avtar 和数据库插件。
在 Avamar Client 安装和注册期间,即使排除防病毒软件中的 avtar.exe 和 avagent.exe 进程也可能不起作用。
Resolution
如果这是 AVE 或单节点锁定为仅将备份指向 Data Domain,请调整数据集以将备份定向到正确的 Data Domain。
如果由于 防病毒问题而未注册插件:暂时禁用防病毒软件并终止正在运行的任何现有防病毒进程。然后,照常重新安装 Avamar Client MSI 程序包。
如果由于 桌面堆分配失败而禁用插件程序,选项如下所示:
- 禁用或删除任何可能遇到内存泄漏的应用程序/程序。与 Microsoft 支持部门协作,以查找有问题的程序。或者,按计划重新启动计算机会暂时刷新桌面堆。
- 增加注册表中的最大堆值,并重新启动 Windows 客户端以使更改生效。使用以下 URL 了解过程和建议的值:
- 首选长期修复(如果无法识别有问题的应用程序或正在识别应用程序时)。
- 将 Avamar“Backup Agent”服务从默认的 NT Authority\SYSTEM 帐户更改为在 Windows 客户端上具有足够权限的域用户帐户,然后重新启动该服务以使更改生效。虽然备份代理服务默认作为 SYSTEM 帐户运行,但您可以使用在 Windows 客户端上至少具有读/写访问权限的任何 NT 域帐户。这是因为 Avamar 服务将不再使用与以系统身份登录的其他程序(包括发生内存泄漏的程序)相同的堆。
- 下面的 URL 提供了有关此解决方法和其他解决方法的更多详细信息:
Affected Products
Avamar Client, Avamar Plug-inArticle Properties
Article Number: 000159530
Article Type: Solution
Last Modified: 19 Nov 2025
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.