NetWorker: NMC Fails to Open With Error "Cannot determine a valid Java Home"

Summary: NMC Fails to Open With Error "Cannot determine a valid Java Home"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Oracle Java Runtime Environment (JRE) is used instead of NetWorker Runtime Environment (NRE)
  • The NetWorker Management Console (NMC) fails to open with the error: "Cannot determine a valid Java Home"
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  • This issue may not appear on all hosts accessing the NMC.

Cause

This is not a NetWorker\NMC issue.

When the NMC is launched, JAVA command javaws.exe is run on the host you are accessing the NMC from. The javaws.exe file is in the Java installation’s bin directory. Issues may occur if an old javaws.exe file remains from a previous installation. In this instance, the operating system is using the wrong javaws.exe to launch the NMC. For example, Java 8 '181' is installed, but '171' is launched instead:
 
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Resolution

Option One:

The preferred runtime environment for NetWorker is the NetWorker Runtime Environment (NRE). Install and configure NRE on the hosts accessing the NMC.

NetWorker Runtime Environment (NRE): Introduction and Installation

If this problem is observed on systems where NRE is installed, check to see if the host also has Oracle Java Runtime Environment (JRE) installed. If Oracle JRE is installed, consult with the system administrator if it can be removed to prevent any conflicts with NRE.

Option Two:

NOTE: This method is typically only required when the host is not using NRE, but instead uses Oracle licensed Java Runtime Environment (JRE).

The following information can be found in the NetWorker Installation Guidehttps://www.dell.com/support/product-details/product/networker/docs

Warning: unable to detect Java Runtime Environment

This message appears when the JRE is not installed on the NMC client.

About this task
For Windows only, the JRE version that is installed on the Console client does not match the Microsoft Internet Explorer version. This message appears on 64-bit Windows systems when you use one of the following combinations:
  • 64-bit version of the browser to connect to the NMC server, but the 32-bit version of JRE is installed.
  • 32-bit version of the browser to connect to the NMC server, but the 64-bit version of JRE is installed.
To resolve this issue:
  • Install JRE on the NMC client.
    • For Windows only, install the correct JRE program for the installed Microsoft Internet Explorer version.
      • For the 32-bit version of the browser, install the 32-bit version of JRE.
      • For the 64-bit version of the browser, install the 64-bit version of JRE.
Use the following procedure to determine the Microsoft Internet Explorer version on the Windows NMC client.

Steps:
  1. Right-click the Microsoft Internet Explorer shortcut and select Properties.
  2. Review the Target Path field.
The target path is on of the following locations:
  • C:\Program Files (x86)\Internet Explorer\ for the 32-bit version of Microsoft Internet Explorer.
  • C:\Program Files\Internet Explorer\ for the 64-bit version of Microsoft Internet Explorer.

Ensure that the correct javaws.exe is used by the operating system when launching the NMC:

  1. Confirm which version of JAVA is installed on your system, open Configure Java.
a. Select Java.
b. Select View:
c. In the Java Runtime Environment Settings window, check both the User and System tabs. There should only be one instance of JAVA installed. Make note of the JAVA version and the installation location. The checkbox indicates that this version of JAVA is enabled.
 
Java Path 
 
d. If there are multiple versions of JAVA installed, remove the older versions. This can be done from the Java Control Panel or Programs and Features.
  1. Open a Windows File Explorer and navigate to C:\
a. In the search bar, enter: javaws.exe
b. As per step 1, c, javaws.exe should only appear under the installation path shown in the JAVA Control Panel.
 
javaws path on the os drive  
NOTE: If your system has multiple volumes, search them as well to ensure that JAVA files are not found elsewhere on the system.

c. If multiple javaws.exe files appear, delete the ones that are not associated with the current Java installation path (step 1, c)

  1. Return to the Java Control Panel
a. Under the General tab, select Settings.
b. In the Temporary Files Settings window, select Delete Files.
c. In the Delete Files and Applications window, check Installed Applications and Applets (all three boxes should be checked):
 
Java control panel deleting cache 
 
d. Click OK, then click OK again.
e. Close the Java Control Panel.
  1. Open a Web Browser and navigate to https://nmc_servername:9000, specifying your NMC server's hostname or IP address.
a. From the NMC web page, launch the NMC.
b. Log in to the NMC to confirm access, a new NMC shortcut should be placed on the desktop.
c. Minimize the NMC and test launching it from the newly created desktop shortcut.
 

For additional instructions, see: NetWorker: How To Clear Java Cache, enable Java Console and Debugging (Oracle Java)

Additional Information

You can confirm that the issue is isolated to JAVA by launching the NMC from the JAVA installation dir. For Example:

Launching NMC from javaws directory
NOTE: When performing the above, ensure to cd to your JAVA installation. The JAVA \bin directory contains javaws.exe. When running the javaws.exe command, ensure to specify your NMC server's resolvable hostname or IP address. 

If the above workaround works, this confirms that there is no issue with NetWorker. This issue is with how JAVA commands are being run by the operating system.

Affected Products

NetWorker

Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000160813
Article Type: Solution
Last Modified: 05 Jun 2025
Version:  4
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