Dell EMC Unity: Failed to get technical advisory with configured proxy (correggibile dall'utente)

Summary: Errori durante la ricezione di avvertenze tecniche

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Symptoms

Quando si tenta di recuperare avvertenze tecniche da Unisphere, viene generato il seguente messaggio di errore:

There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'

EMCSystemLogFile.log shows the following:
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC


Il comando curl per controllare la connettività al server proxy ha esito negativo:

# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v

Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com


L'aggiunta del server proxy al comando curl ha esito positivo.

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive


<--snip-->
(vedere l'output completo nelle note)

Cause

In questo caso, il cliente non consente l'accesso diretto a un server DNS e utilizza solo il server proxy per uscire.  La causa di questo problema è che la connessione tra colu.emc.com e il server proxy è stata chiusa prima del completamento del trasferimento dei dati tra Unity e il server proxy.  Ciò sembra essere dovuto al modo in cui curl gestisce le connessioni.

Resolution

Correzione
La correzione di questo problema verrà inclusa in una versione futura di Dell EMC Unity OE.  Consultare questo articolo della Knowledge Base per gli aggiornamenti.

Soluzione alternativa
Non utilizzare il server proxy per il recupero di avvertenze tecniche o configurare un'esclusione temporanea per Unisphere fino al rilascio del codice che corregge questo problema.

Additional Information

Quando si aggiunge 'proxy server URL' al comando curl, l'operazione ha esito positivo:

# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1...   (proxy server IP)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.

Affected Products

Dell EMC Unity Family
Article Properties
Article Number: 000182700
Article Type: Solution
Last Modified: 19 Aug 2021
Version:  3
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