IDPA: How to soft reset iDRAC from DP4400, DP5x00, or DP8x00 ESXi node
Summary: How to soft reset Integrated Dell Remote Access Controller (iDRAC) from DP4400, DP5x00, or DP8x00 ESXi node
Instructions
Purpose
If the iDRAC is not responding, and the "racadm racreset" command from the iDRAC command line is not working.
This article provides the steps to perform a restart remotely from the Integrated Data Protection Appliance (IDPA) or PowerProtect Data Protection series ESXi hosts.
Cause:
When it is unable to log in to the iDRAC UI, or the iDRAC is not responding to the "racadm racreset" command in an SSH session:
Resolution:
Try to reset it using the following iDRAC Service Module (iSM) command:
- Log in to the ESXi with the root account and run the command:
/opt/dell/srvadmin/iSM/bin/Invoke-iDRACHardReset
This will reset the iDRAC. Do you want to proceed with this operation? [(Y/N), Default=N]: Y or /opt/dell/idpa/bin/ipmitool mc reset cold
- Find the iDRAC IP address with the command:
/opt/dell/idpa/bin/ipmitool lan print |grep "IP Address" IP Address Source : Static Address IP Address : 10.XX.XX.XX
- From the IDPA ESXi host, SSH to the iDRAC with the internal IP address 169.254.0.1:
ssh root@169.254.0.1 root@169.254.0.1's password: racadm>>
Additional Information
Remote iDRAC hard reset
iDRAC may become unresponsive due to various reasons. iSM can fully reset an unresponsive iDRAC8 or iDRAC9 controller by temporarily removing power to the iDRAC controller without affecting the operating system production. This feature can only be disabled from the iDRAC Service Module page in iDRAC using any of the iDRAC interfaces.
Details about the reset options could be found in the Dell Integrated Dell Remote Access Controller 9 User's Guide.
See KB PowerEdge: How to Reset the Integrated Dell Remote Access Controller (iDRAC) for other options on how to reset iDRAC.