NetWorker Linux server: Mail notification not sending the message to the relay server

Summary: Email notifications are not being sent or received from a Linux NetWorker server.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker server is configured to send mail notifications with Linux operating system "mail" command. In the NetWorker Administration Guide, a few examples are given, for which the options are described:
  • -s Specifies the subject.
  • -r Sets the from address. 
Triggered events are not receiving their email notifications.

Cause

It seems email messages are never sent since the command is somehow found incorrect when using the "-S" flag to specify a relay server. This results in email messages being sent to /root/dead.letter.

Resolution

A workaround to allow sending mail with extended flags (provided they are not supported from NMC side) is presented below.

In the below scenario, in order to use mailx to send mails out of the internal network, the external relay or SMTP that is handling all email messages, must be specified for email messages to be delivered to the correct address.
  1. Create a text file: /usr/bin/mail_nmc.
touch /usr/bin/mail_nmc
chmod 755 /usr/bin/mail_nmc
  1. Open the file and write the following inside:
exec mailx -S smtp="RELAY_IP_ADDRESS:PORT" "$@" < /dev/stdin

Replace RELAY_IP_ADDRESS and PORT with the external relay or SMTP that is handling the email messages.
  1. Configure the NetWorker notifications from the NMC to use the mail command created in step 1:
/usr/bin/mail_nmc -r sender@domain.local -s "subject text" recipient@domain.local

Affected Products

NetWorker Family
Article Properties
Article Number: 000193794
Article Type: Solution
Last Modified: 23 Nov 2021
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.