AppSync: Uploading .xml license file in UI receives error: Adding the license failed due to "Invalid license file"

Summary: Uploading .xml license file in UI receives error: Adding the license failed due to "Invalid license file".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In AppSync UI, when uploading .xml license in Settings > License > Upload, receive an error:

Adding the license failed due to "Invalid license file"

 

Screenshot 1.png

 

Cause

The first scenario seen was the entire <lockingID> section was missing from the license file.
There should be a lockingID section like the following:

 

<LockingIds>

	<LockingId>

		<LockingIdCode>HOSTID</LockingIdCode>

		<LockingIdValue>value</LockingIdValue>

	</LockingId>

</LockingIds>

 

The second scenario seen was the LockingIdCode being inappropriately found to be XIOD like so:

 

<LockingId>

	<LockingIdCode>XIOID</LockingIdCode>

 

When it should be HOSTID

 

<LockingId>

	<LockingIdCode>HOSTID</LockingIdCode>

 

Resolution

The internal licensing generation mechanism is updated to ensure the Locking ID section is populated.

 

A new license is needed. Obtain a new license from the licensing team.

 

Additional Information

AppSync 4.2 and later supports XML type licenses.

Affected Products

AppSync
Article Properties
Article Number: 000193800
Article Type: Solution
Last Modified: 10 Sep 2025
Version:  4
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