PowerStore: Las máquinas virtuales de Windows se bloquean durante el arranque con el código de detención 0xC000021A después de migrar a PowerStore
Summary: La migración de máquinas virtuales desde otro arreglo de almacenamiento a PowerStore puede dar como resultado una pantalla azul durante el arranque. Si la máquina virtual se reinicia después de la migración, es probable que aparezca una pantalla azul con el código de detención 0xC000021A, pero es posible que haya otros códigos de detención. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Las máquinas virtuales que utilizan el arranque de UEFI se encuentran con una pantalla azul durante el arranque.
Este problema se produce con las versiones sin parches de ESXi. Consulte el KB 2137402 de VMware.
Esto se aplica en los siguientes:
Este problema se puede identificar en los registros de PowerStore mediante la búsqueda de WRITE with size exceeding MAX TRANSFER:
Este problema se produce con las versiones sin parches de ESXi. Consulte el KB 2137402 de VMware.
Esto se aplica en los siguientes:
- Versiones de ESXi 6.5, 6.7 y 7.0.
- VM de Windows Server 2012, 2016 y 2019.
- VMFS5 o VMFS6.
- Migraciones activas o en frío.
Este problema se puede identificar en los registros de PowerStore mediante la búsqueda de WRITE with size exceeding MAX TRANSFER:
The error displayed is "parse_error_full:364: WRITE with size exceeding MAX TRANSFER SIZE (2056 >= 2048)":
O contando el número de instancias.
svc_journalctl | grep "WRITE with size exceeding MAX TRANSFER" | wc -l 1131348
Cause
Los hosts no están configurados según las prácticas recomendadas de PowerStore:
https://dl.dell.com/content/manual37523884-dell-emc-powerstore-host-configuration-guide.pdf
En particular, consulte la sección sobre los valores de configuración recomendados:
Disk.DiskMaxIOSize = 1024
Esto expone un problema conocido en ESXi que se resuelve en las versiones más recientes.
Resolution
Ejecute el siguiente comando en los hosts ESXi para comprobar el valor actual:
Para PowerStore, el Int Value debe establecerse en 1024:
Ejecute el siguiente comando en cada host ESXi para establecer el valor correcto:
esxcli system settings advanced list -o "/Disk/DiskMaxIOSize"
Para PowerStore, el Int Value debe establecerse en 1024:
Path: /Disk/DiskMaxIOSize Type: integer Int Value: 1024 Default Int Value: 32767 Min Value: 32 Max Value: 32767 String Value: Default String Value: Valid Characters: Description: Max Disk READ/WRITE I/O size before splitting (in KB)
Ejecute el siguiente comando en cada host ESXi para establecer el valor correcto:
esxcli system settings advanced set -o "/Disk/DiskMaxIOSize" --int-value 1024
Additional Information
El KB 000182665 describe el mismo problema, pero con distintos síntomas.
Affected Products
PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9000XArticle Properties
Article Number: 000196159
Article Type: Solution
Last Modified: 14 Dec 2022
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.