PowerStore:PowerStoreに移行した後、Windows VMが起動時にStopコード0xC000021Aでクラッシュする 

Summary: 別のストレージ アレイからPowerStoreにVMを移行すると、起動時にブルー スクリーンが発生する場合があります。移行後にVMを再起動すると、STOPコード0xC000021Aでブルー スクリーンが表示される可能性がありますが、他のSTOPコードの可能性もあります。

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Symptoms

UEFI起動を使用しているVMは、起動中にブルー スクリーンになります。
この問題は、パッチが適用されていないバージョンのESXiで発生します。VMwareのKB 2137402を参照してください。

これは次の場合に適用されます。
  • ESXiバージョン6.5、6.7、7.0
  • Windows Server 2012、2016、2019 VM
  • VMFS5またはVMFS6
  • ライブ移行またはコールド移行


この問題は、PowerStoreログで「WRITE with size exceeding MAX TRANSFER」を検索することで、特定できます。
The error displayed is "parse_error_full:364: WRITE with size exceeding MAX TRANSFER SIZE (2056 >= 2048)":


または、次のような行の数をカウントします。

svc_journalctl | grep "WRITE with size exceeding MAX TRANSFER" | wc -l 1131348

Cause

ホストはPowerStoreのベスト プラクティスに従って設定されていません。
https://dl.dell.com/content/manual37523884-dell-emc-powerstore-host-configuration-guide.pdf


特に、次の推奨設定値のセクションを参照してください。

Disk.DiskMaxIOSize = 1024


ここではESXiでの既知の問題が公開されており、これらは最新バージョンで解決されます。


Resolution

ESXiホストで次のコマンドを実行して、現在の値を確認します。
esxcli system settings advanced list -o "/Disk/DiskMaxIOSize"

PowerStoreの場合、Int Valueは1024に設定する必要があります。
Path: /Disk/DiskMaxIOSize Type: integer Int Value: 1024 Default Int Value: 32767 Min Value: 32 Max Value: 32767 String Value: Default String Value: Valid Characters: Description: Max Disk READ/WRITE I/O size before splitting (in KB)


ESXiホストで次のコマンドを実行して、正しい値を設定します。
esxcli system settings advanced set -o "/Disk/DiskMaxIOSize" --int-value 1024

Additional Information

KB 000182665は、同じ問題について説明していますが、症状は異なります。

Affected Products

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000T

Products

PowerStore 9000X
Article Properties
Article Number: 000196159
Article Type: Solution
Last Modified: 14 Dec 2022
Version:  7
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