NetWorker: Scanner does not create recoverable saveset database entries.
Summary: An enhancement in scanner utility's disk performance causes tape savesets scanned to be unrecoverable without administrative intervention.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- After running scanner on a tape volume, a saveset will only show the final fragment address in mminfo, for example:
mminfo -ar ssid,mediafile,mediarec,first,last,fragsize,fragflags -q volume=volume_name ssid media-file record first last frag-size frag-flags 3989758634 26 0 51140091900 51203151695 61 MB cb
- Lack of a fragment in mminfo showing first value of 0 (true start of saveset).
- Error attempting even saveset recovery: Recover failed from NSR server `server': No volumes found for recover.
Cause
This issue is a result of enhancement for disk-family media in NetWorker 19.5 and above.
Resolution
The code fix will be available in upcoming versions of NetWorker 19.6.1.2 or .3 and 19.7.0.1.
Workaround:
Workaround:
- Add the -F switch as part of scanner command.
NOTE: This will change saveset retention even if the saveset already exists in the media database (-y switch can be used to set retention manually).
- Use the standalone scanner binary from an earlier version, ideally 19.4.0.6
Affected Products
NetWorker FamilyArticle Properties
Article Number: 000201516
Article Type: Solution
Last Modified: 22 Feb 2023
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.