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CloudLink: CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.

Summary: CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.
  • All agent policies are set to Automatic upgrade.
  • Following the CloudLink server upgrade to version 7.1.5, no agent was upgraded and all agents report version as 7.1.133.
  • Tried to set a policy to manual upgrade in order to upgrade the agent manually, but the upgrade option is unavailable for all agents even if the policy is manual.
  • Uninstalled the agent on one of the protected VMs and installed the agent again. It was showing the original agent version of 7.1.133

Cause

Working as designed.
Occasionally the same agent is used for versions of two releases.
Occasionally there is a difference in Linux agent version but no change for Windows agent.

Resolution

This is working as designed. Check the customer's agent Operating System type, CloudLink source code, and destination code version to check if the agent version must be upgraded.

In this instance, the agent version does not need to be upgraded if the current version matches the mapping matrix as below:
CloudLink Version      Windows Agent        Linux Agent
CloudLink 7.1.1 7.1 (build 9) 7.1 (build 32)
CloudLink 7.1.2 7.1 (build 111) 7.1 (build 111)
CloudLink 7.1.3 7.1 (build 133) 7.1 (build 136)
CloudLink 7.1.4 7.1 (build 133) 7.1 (build 136)
CloudLink 7.1.5 7.1 (build 133) 7.1 (build 140)
CloudLink 7.1.6 7.1 (build 133) 7.1 (build 140)

Products

CloudLink
Article Properties
Article Number: 000212227
Article Type: Solution
Last Modified: 26 Jul 2023
Version:  3
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