PowerProtect: File System Agent Backup Does not Complete With Error "ABA0002: FS-Image"
Summary: File System Agent Backup fails due to not having enough free space to create a snapshot.
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Symptoms
PowerProtect Data Manager File System agent backup fails with an error message similar to the following:
ABA0002: FS-Image: Unable to backup FILE_SYSTEM asset <drive letter> on host hostname.domain.com to storage target <Storage details> because of an agent issue. The protection policy backup was unsuccessful because of an agent issue. Review the error message for a resolution. If there is no resolution, and the issue persists, contact Dell Customer Support.
On checking more details of the job within the PowerProtect Data Manager console, error messages similar to the following are found:
The protection policy backup was unsuccessful because the Agent failed with the following error: 2023-04-12T00:01:15.446Z [TRACE_ID_b4cba8a52ae3e4b8_EXEC_ID_ad799a85085e9803]186907:ddfssv:Unable to create the VSS snapshot. Reason: Insufficient storage available to create either the shadow copy storage file or other shadow copy data. . status is: -2147212513. 2023-04-12T00:01:15.446Z [TRACE_ID_b4cba8a52ae3e4b8_EXEC_ID_ad799a85085e9803]VSS OTHER: ERROR: VSS failed to process snapshot: 2023-04-12T00:01:15.446Z [TRACE_ID_b4cba8a52ae3e4b8_EXEC_ID_ad799a85085e9803]189309:ddfssv:Unable to create a snapshot. Please check the Event viewer on the host for more details. 2023-04-12T00:01:15.446Z [TRACE_ID_b4cba8a52ae3e4b8_EXEC_ID_ad799a85085e9803]198477:ddfssv: Unable to create the snapshot.
The same error messages are found in the ddfscon and ddfssv log files for fsagent on the file system server.
Cause
There is not enough space available to create a VSS snapshot on the disk that is selected for storing VSS snapshots.
Resolution
The following steps can be taken to resolve this issue:
- Connect to the Microsoft Windows host for which backup is failing.
- Identify where snapshots are configured to be written and create free space. If free space cannot be created on the drive selected, snapshots can be changed to be stored on a drive with enough free space.
- To identify where snapshots are configured to be written the following steps can be followed for Windows Server 2008, 2008 R2, 2012, 2012 R2, 2016, 2016 R2, 2019, 2022:
- Open Computer in Microsoft Windows Explorer.
- Right click the drive letter which is mentioned in the error message and select Configure Shadow Copies
- On the Shadow Copies window, highlight drive letter in question and select Settings
- On the Settings window within the Storage Area section, Located on this volume has a drop-down menu. The drive letter displayed when the window is opened is the drive letter in use for storing VSS snapshots.
- In the same dropdown for Located on this volume: If the user would like to change the storage location for snapshots, the user can select drive letter with enough free space.
- By default, Maximum Size is set to Use limit and a limit is defined. The user must decide if they want to have a limit defined for storing snapshots or you want to select No limit option. If you have a dedicated drive for storing snapshots, you can select Maximum Size.
- After making your selections, select OK button on the Settings window and Shadow Copies window.
Affected Products
PowerProtect Data Manager, PowerProtect Data Manager EssentialsArticle Properties
Article Number: 000212439
Article Type: Solution
Last Modified: 15 Aug 2025
Version: 5
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