Latitude and Precision Laptop May Have Blue Screen Error After Installing Windows 11 21H2
Summary: The customer may encounter a Windows blue screen error while installing the Windows 11 21H2.
Symptoms
Affected Platforms:
- Latitude 5340
- Latitude 5540
- Latitude 7340
- Precision 3580
- Precision 3581
Affected Operating Systems:
- Windows 11 21H2
The blue screen error codes: DRIVER_POWER_STATE_FAILURE or DRIVER_IRQL_NOT_LESS_OR_EQUAL appear while installing Windows 11 21H2 RTM ISO 22000.194 or 22000.258.
Cause
This is a Microsoft known issue. The Windows 11 21H2 USB inbox driver contains an issue that does not properly handle the privacy notification and causes the blue screen Error.
Resolution
This issue does not occur on Windows 11 22H2 version 22621 or later.
If Windows 11 21H2 is required, then Microsoft Hotfix KB5014019 must be imported into the Windows 11 ISO before installing Windows 11.
To import KB5014015 into the Windows 11 21H2 ISO, follow these steps:
- Download and install the Windows Assessment and Deployment Kit (Windows ADK)
- Download the hotfix KB5014019 from the Microsoft Website.
- Copy the files from install ISO to a folder called c:\temp\src
- Copy hotfix KB5014019 to a folder called c:\temp\hotfix
- Open a command prompt with administrator rights.
- Mount the image using this command:
Dism /Mount-Image /ImageFile:C:\temp\src\install.wim /Index:1 /MountDir:C:\temp\mount
- Import the hotfix using this command:
Dism /Image:"C:\temp\mount" /Add-Package /PackagePath="C:\temp\hotfix\windows10.0-KB5014019-x64.msu" /LogPath=C:\temp\mount\dism.log
- Unmount the image using this command:
Dism /Unmount-Image /MountDir:C:\temp\mount /Commit
Windows Imaging Format (WIM) is now updated, use the new image to install Windows.
Reference the Microsoft website for detail:
https://learn.microsoft.com/windows-hardware/manufacture/desktop/servicing-the-image-with-windows-updates-sxs?view=windows-11