PowerEdge: ESXi Purple Screen When the IO Load is High

Summary: Purple screen occurring randomly when the I/O load is high. There are no obvious SAN issues or array-related issues.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Environment: Hardware Dell 9116 switches
VMware OS: ESXi any release (seen for the first time in ESXi 7.0.3)

Numerous "path failed" and "path in doubt" before the purple screen:

Screenshot of purple screen:

VMware ESXi 7.0.3 [Releasebuild-21313628 x86_64]
#PF Exception 14 in world 2496356:vmm1:VA1PWCS IP 0x420023bf41db addr 0x28
PTEs:0x0;
cr0=0x80050031 cr2=0x28 cr3=0x815439b000 cr4=0x152668
FMS=06/55/7 uCode=0x5003302
frame=0x453a3061b730 ip=0x420023bf41db err=0x0 rflags=0x10206
rax=0x0 rbx=0x431655444ec0 rcx=0x76
rdx=0x49 rbp=0xc rsi=0x420023c91d46
rdi=0x4309a8b1da20 r8=0x1 r9=0x78a78c
r10=0xd78a78c r11=0x453a3061b640 r12=0x5fc
r13=0x43165559f160 r14=0x0 r15=0x1
*PCPU11:2496356/vmm1:VA1PWCSQL840
PCPU  0: SVVVVVVVVVVVVVVVSVSVVSVVVSVSVSSV
Code start: 0x420022c00000 VMC uptime: 22:18:04:37:412
0x453a3061b7f0:[0x420023bf41db]qedfc_process_error_detect@(qedf)#<None>+0x537 stack: 0x41ffe2ceb830
0x453a3061b840:[0x420023bd01da]qedfc_fp_process_cqes@(qedf)#<None>+0x47f stack: 0x420022cddf68
0x453a3061b890:[0x420023bd08a3]qed_msix_fp_int@(qedf)#<None>+0x18 stack: 0x4302b5832580
0x453a3061b8b0:[0x420022cde0e3]IntrCookieBH@vmkernel#nover+0x17c stack: 0x453a3061b8d0
0x453a3061b940:[0x420022cc0367]BH_DrainAndDisableInterrupts@vmkernel#nover+0x170 stack: 0x0
0x453a3061b9c0:[0x420022cdfce6]IntrCookie_VmkernelInterrupt@vmkernel#nover+0xb3 stack: 0xffffffffffffff8a
0x453a3061b9e0:[0x420022d55aac]IDT_IntrHandler@vmkernel#nover+0x9d stack: 0x0
0x453a3061ba00:[0x420022d4e067]gate_entry@vmkernel#nover+0x68 stack: 0x0
0x453a3061bac8:[0x420022c84608]Power_ArchPerformWait@vmkernel#nover+0x70 stack: 0x420042c00980
0x453a3061bad0:[0x420022c84776]Power_ArchSetCState@vmkernel#nover+0x8f stack: 0x0
0x453a3061bb20:[0x420022fae43c]CpuSchedIdleLoopInt@vmkernel#nover+0x275 stack: 0x420042c00100
0x453a3061bb90:[0x420022fb2502]CpuSchedDispatch@vmkernel#nover+0x1aff stack: 0x420042c00140
0x453a3061bdd0:[0x420022fb3257]CpuSchedWait@vmkernel#nover+0x2f4 stack: 0x7
0x453a3061bf50:[0x420022fb37ee]CpuSched_VcpuHalt@vmkernel#nover+0x13f stack: 0x453a3061f000
0x453a3061bfa0:[0x420022d2d313]VMMVMKCall_Call@vmkernel#nover+0x108 stack: 0x0
0x453a3061bfe0:[0x420022d59489]VMKVMM_ArchEnterVMKernel@vmkernel#nover+0xe stack: 0x420022d5947c
base fs=0x0 gs=0x420042c00000 Kgs=0x0

Cause

The issue was determined as a 9116 switch issue (there are two of these switches in each set of chassis), the issue jumbles the FCoE data.

Resolution

If you are facing this issue, upgrade the firmware on the MX7000 Chassis, switches, and blades to the latest qualified release.

Affected Products

Dell EMC Networking MX9116n, PowerEdge MX7000, VMware ESXi 7.x, VMware ESXi 8.x
Article Properties
Article Number: 000214640
Article Type: Solution
Last Modified: 13 May 2025
Version:  5
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