PowerProtect: Backups may fail with "Unable to send request to unreachable host using address and port 7000"

Summary: This article addresses a backup failure issue in PowerProtect Data Manager 19.14 with clients using dual stack.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following error message may be received when backups are failing when clients are using dual stack. The error is seen in ADM (/var/log/brs/adm/adm.log) logs:

com.emc.dpsg.ecdm.adm.shared.exception.AdmException: Unable to send request to unreachable host 2196a9d9-3205-4507-81e0-d82d3a284f7a using address <ip_address> and port 7000

 

The following error is seen in AgentService logs from the backup client (DPSAPPS\AgentService\logs):

ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI1882\main.py-update_configs()-Line 249- error in updating configs: Error occurred while getting IP from FQDN: [Errno 11004] host not found.

 

NOTE: This article only applies to PowerProtect Data Manager 19.14. This article does NOT apply to any versions before 19.14.

 

Cause

An issue is identified that may happen in dual-stack environments (IPv4 or IPv6) where a mismatch between PowerProtect Data Manager preferred IP address for the backup client and agent service binding to the backup client IP address.

 

Resolution

Resolution:

  1. On the Application Hosts, check the Agent Service Binding Address using the below command:

    • Linux or AIX:
      netstat -an | grep <7000|port number>
    • Windows:
      netstat -an | findstr <7000|port number>
  2. On the PowerProtect Data Manager server, check the resolution of the Preferred Address following the below path:

    1. Go to the Application Agents page > select the Host > More Actions > Set Preferred Address. Capture the preferred address.
    2. Use the Preferred Address from step 2a and run the command:
      curl -kv http://<preferred address>:<port number>/greetings

    If there is failure, go to step 3.

  3. If there is a failure in step 2, check If there is a mismatch in the address of the IP stack from step 1 and 2.

    1. From the PowerProtect Data Manager UI, select the Application Host and change the Preferred Address to match the IP stack in step 1.
      1. Go to the Application Agents page > select the Host > More Actions > Set Preferred Address and change it to match the IP stack from step 1.
        OR
    2. On the Application Agent, change the binding address of agents to match the Preferred Address selected by user.
      1. Run the installer and choose as the "Preferred application host address for communication" the IP found in step 2.

 

IMPORTANT NOTE: Name resolutions and reverse lookups must be configured to ensure the following:
  • The FQDNs of application agent hosts that use FQDN as their preferred host address resolve to a valid IPv4 or IPv6 address.
  • Each application-agent host that uses FQDN as its preferred host address resolves the FQDN of PowerProtect Data Manager to an IP address of the same protocol that it uses. For example, if a host uses IPv4, it resolves the FQDN of PowerProtect Data Manager to an IPv4 address.

 

Affected Products

PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software
Article Properties
Article Number: 000215647
Article Type: Solution
Last Modified: 15 Apr 2024
Version:  3
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