PowerProtect: Yedeklemeler "Adres ve bağlantı noktası 7000 kullanılarak erişilemeyen ana bilgisayara istek gönderilemiyor" hatasıyla başarısız olabilir

Summary: Bu makalede, çift yığın kullanan istemcilerle PowerProtect Data Manager 19.14'te yaşanan yedekleme hatası sorunu ele alınmaktadır.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

İstemciler çift yığın kullanırken yedeklemeler başarısız olduğunda aşağıdaki hata mesajı alınabilir. Hata, ADM (/var/log/brs/adm/adm.log) günlüklerinde görülür:

com.emc.dpsg.ecdm.adm.shared.exception.AdmException: Unable to send request to unreachable host 2196a9d9-3205-4507-81e0-d82d3a284f7a using address <ip_address> and port 7000

 

Yedekleme istemcisinden (DPSAPPS\AgentService\logs) alınan AgentService günlüklerinde aşağıdaki hata görülür:

ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI1882\main.py-update_configs()-Line 249- error in updating configs: Error occurred while getting IP from FQDN: [Errno 11004] host not found.

 

NOT: Bu makale yalnızca PowerProtect Data Manager 19.14 için geçerlidir. Bu makale 19.14'ten önceki sürümler için geçerli DEĞİLDİR.

 

Cause

Çift yığınlı ortamlarda (IPv4 veya IPv6) PowerProtect Data Manager'ın yedekleme istemcisi için tercih ettiği IP adresi ile aracı hizmetinin yedekleme istemcisi IP adresine bağlanması arasında uyumsuzluk yaşanabilecek bir sorun tanımlanmıştır.

 

Resolution

Çözüm:

  1. Uygulama Ana Bilgisayarlarında, aşağıdaki komutu kullanarak Aracı Hizmeti Bağlama Adresini kontrol edin:

    • Linux veya AIX:
      netstat -an | grep <7000|port number>
    • Windows:
      netstat -an | findstr <7000|port number>
  2. PowerProtect Data Manager sunucusunda, aşağıdaki yolu izleyerek Preferred Address'in çözünürlüğünü kontrol edin:

    1. Application Agents sayfasına > gidin, Daha Fazla>İşlem Yap>, Tercih Edilen Adresi Ayarla öğesini seçin. Tercih edilen adresi yakalayın.
    2. 2a adımındaki Preferred Address ifadesini kullanın ve şu komutu çalıştırın:
      curl -kv http://<preferred address>:<port number>/greetings

    Hata varsa 3. adıma gidin.

  3. 2. adımda bir hata varsa 1. ve 2. adımdaki IP yığınının adresinde uyumsuzluk olup olmadığını kontrol edin.

    1. PowerProtect Data Manager kullanıcı arayüzündenUygulama Ana Bilgisayarını seçin ve Preferred Address değerini, 1. adımdaki IP yığınıyla eşleşecek şekilde değiştirin.
      1. Application Agents sayfasına > gidin, Daha Fazla Eylem Barındır>, Tercih Edilen>Adresi Ayarla seçeneğini belirleyin ve 1. adımdaki IP yığınıyla eşleşecek şekilde değiştirin.
        VEYA
    2. Uygulama Aracısında, aracıların bağlama adresini kullanıcı tarafından seçilen Tercih Edilen Adres ile eşleşecek şekilde değiştirin.
      1. Yükleyiciyi çalıştırın ve "İletişim için tercih edilen uygulama ana bilgisayar adresi" olarak 2. adımda bulunan IP'yi seçin.

 

ÖNEMLİ NOT: Aşağıdakilerin sağlanması için ad çözümlemeleri ve geriye doğru aramalar yapılandırılmalıdır :
  • Tercih edilen ana bilgisayar adresi olarak FQDN'yi kullanılan uygulama aracı ana bilgisayarlarının FQDN'leri, geçerli bir IPv4 veya IPv6 adresine çözümler.
  • Tercih edilen ana bilgisayar adresi olarak FQDN'yi kullanan her uygulama aracı ana bilgisayarı, PowerProtect Data Manager'ın FQDN'sini kullandığı protokolün IP adresine çözümler. Örneğin, bir ana bilgisayar IPv4 kullanıyorsa PowerProtect Data Manager'ın FQDN'sini bir IPv4 adresine çözümler.

 

Affected Products

PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software
Article Properties
Article Number: 000215647
Article Type: Solution
Last Modified: 15 Apr 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.