Dell Unity: U polí s kódem 5.3.0 s povolenou aplikací SupportAssist může po ~2 měsících provozu docházet k panice procesoru úložiště (SP) (opravitelné uživatelem)
Summary: Pole Unity s kódem 5.3.0.0.5.120 s povolenou aplikací SupportAssist mohou po přibližně 2 měsících provozu s konfigurací dvou SCG nebo po přibližně 4 měsících s konfigurací s jednou SCG nebo přímým připojením zaznamenat paniku SP. ...
Symptoms
5.3.0.0.5.120 Aplikace SupportAssist je nakonfigurována a povolena pro vzdálený přístup.
Ovlivněny jsou konfigurace přímého připojení i brány.
Panika procesoru úložiště a neočekávané restartování po přibližně 2 měsících provozu při použití dvou konfigurací
SCG, panika procesoru úložiště a neočekávané restartování přibližně po 4 měsících provozu s jednou konfigurací SCG nebo přímým připojením.
Cause
K panice by mělo dojít pouze na primárním procesoru úložiště, na kterém běží proces ESE, a po panice se prostředky uvolní.
Resolution
Tento problém je vyřešen v operačním prostředí Unity (OE) verze 5.3.1.0.5.008.
Řešení:
K dispozici je několik alternativních řešení; Podrobné kroky pro jednotlivá zástupná řešení najdete v části Další informace.
Additional Information
Možnost #1 zástupného řešení:
Restartování aplikace SupportAssist v případě, že se počet procesů zombie curl zvýší, tyto procesy se vymažou a zabrání panice procesoru úložiště. Doporučená prahová hodnota pro restartování aplikace SupportAssist je 5 000. Níže jsou uvedeny příkazy pro kontrolu počtu procesů zombie (nefunkčních) curl a restartování aplikace SupportAssist.
14:01:20 service@none spb:~/user# ps -ef |grep curl|grep defunct|wc -l
4702 <----------------Aktuální počet procesů
zombie curl 14:01:52 service@none spb:~/user# svc_supportassist --restart
Probíhá restartování........ Dokončena!
14:03:59 service@none spb:~/user# svc_supportassist --status
Stav: Typ běhu
: Připojení prostřednictvím serveru
brány Konektivita: Dosažitelná
primární brána: https://1.2.3.4:9443 (dosažitelná)
Vzdálený přístup:
Ano, RSC povoleno: Ne
verze: 4.7.7.21
Inicializováno:
Ano Režim proxy: žádný
14:04:22 service@none spb:~/user# ps -ef |grep curl|grep deignct|wc -l
0 <----------------- Počet procesů zombie curl po restartování
aplikace SupportAssistMožnost zástupného řešení #2:
Byl vyvinut nový skript UDoctor (udoctor_update_supportassist), který je postupně zpřístupňován pro připojená pole Unity. Pokud bude nový skript Udoctor přijat a nainstalován, vymaže všechny zombie (nefunkční) curl procesy a také zabrání akumulaci jakýchkoli nových zombie (zaniklých) curl procesů v budoucnu.
Skript UDoctor se automaticky nasdílí do systémů, které mají povolenou funkci Call Home, které volají domů a označují, že mají nainstalovanou verzi 5.3.0. V minulosti byly upřednostňovány systémy, které měly vysoký počet zombie procesů, ale tato priorita byla odstraněna a nyní urychlujeme zavádění na všechny systémy, které se připojují k domovu s označením 5.3.0. Po odeslání balíčku do systému se zobrazí výstraha podobná té, která je zobrazena:
Balíčky UDoctor se používají k použití cílených aktualizací, alternativních řešení a změn konfigurace pole Unity, a to nezávisle na úplném upgradu prostředí OE softwaru.
Viz článek znalostní databáze Dell Unity: Balíček UDoctor (xxxxxx) je nyní k dispozici pro instalaci. (Oprava uživatelem), kde zjistíte, zda je k dispozici nový balíček UDoctor a jak přijmout a nainstalovat nový balíček UDoctor .
POZNÁMKA 1:
Při upgradu (NDU) prostředí Unity OE dojde k přepsání všech změn provedených balíčkem UDoctor. To znamená, že jakmile bude oprava softwaru k dispozici v nové verzi Unity OE, je možné provést standardní NDU a nejsou vyžadovány žádné další kroky.
POZNÁMKA 2:
Neexistuje žádný způsob, jak přepsat proces inventáře nebo odeslání a vynutit, aby se balíček UDoctor nasdílel do konkrétního systému Unity. Proces inventarizace/nabízení probíhá každý týden. Pro zákazníky, kteří chtějí opravu provést dříve, je správným řešením upgrade na prostředí Unity OE verze 5.3.1.0.5.008 (5.3 SP1). Případně mohou zákazníci využít jiná výše uvedená alternativní řešení.