Dell Unity. В массивах с кодом 5.3.0 с включенной функцией SupportAssist могут возникать критические ошибки процессора СХД (SP) после ~2 месяцев безотказной работы (исправляется пользователем)
Summary: Массивы Unity с кодом 5.3.0.0.5.120 с включенной функцией SupportAssist могут испытывать сбой процессора СХД после работы в течение примерно 2 месяцев с конфигурацией с двумя SCG или примерно через 4 месяца с одной конфигурацией SCG или прямым подключением. ...
Symptoms
5.3.0.0.5.120 Приложение SupportAssist настроено и включено для удаленного доступа.
Это влияет как на конфигурации прямого подключения, так и на конфигурации шлюза.
Критическая ошибка процессора СХД и неожиданная перезагрузка примерно через 2 месяца работы с двумя
конфигурациями SCG, критическая ошибка процессора СХД и непредусмотренная перезагрузка примерно через 4 месяца работы с одной конфигурацией SCG или с прямым подключением.
Cause
Критическая ошибка должна возникать только на основном процессоре СХД, где выполняется процесс ESE. После такой ошибки освобождаются ресурсы.
Resolution
Эта проблема устранена в операционной среде Unity (OE) версии 5.3.1.0.5.008.
Решение:
Существует несколько обходных путей; Подробные инструкции по каждому временному решению см. в разделе «Дополнительная информация».
Additional Information
Вариант временного решения #1:
Перезапуск SupportAssist, когда количество процессов zombie curl стало большим, очистит их и предотвратит критическую ошибку процессора СХД. Рекомендуемое пороговое значение для перезапуска SupportAssist — 5000. Команды для проверки количества зомби-процессов (несуществующих) curl и перезапуска SupportAssist приведены ниже.
14:01:20 service@none spb:~/user# ps -ef |grep curl|grep defunct|wc -l
4702 <----------------Текущее количество процессов
зомби curl 14:01:52 service@none spb:~/user# svc_supportassist --restart
Выполняется перезапуск........ Завершена!
14:03:59 service@none spb:~/user# svc_supportassist --status
Состояние: Тип бега
: Подключение через сервер
шлюза Возможности подключения: Основной шлюз достижим:
https://1.2.3.4:9443 (достижим)
Удаленный доступ:
Да, RSC включено: Версия отсутствует
: 4.7.7.21
. Инициализировано:
Да Режим прокси-сервера: нет
14:04:22 service@none spb:~/user# ps -ef |grep curl|grep defunct|wc -l
0 <----------------- Количество процессов zombie curl после перезапуска
SupportAssistВариант временного решения #2.
Был разработан новый сценарий UDoctor (udoctor_update_supportassist), который развертывается поэтапно для подключенных массивов Unity. Если новый скрипт Udoctor будет принят и установлен, он очистит все зомби-(несуществующие) процессы curl, а также предотвратит накопление любых новых зомби-(несуществующих) процессов curl в будущем.
Сценарий UDoctor автоматически отправляется в системы, в которых включена функция callhome, которая указывает на установленную версию Call Home 5.3.0. В прошлом приоритет отдавался системам с большим количеством зомби-процессов, но этот приоритет был устранен, и теперь мы ускоряем развертывание во всех системах, которые подключаются к дому с указанием версии 5.3.0. После отправки пакета в систему отобразится оповещение, подобное показанному:
Пакеты UDoctor используются для применения целевых обновлений, временного решения проблем и изменения конфигурации массива Unity независимо от полного обновления программного обеспечения операционной среды.
См. статью базы знаний Dell Unity. Пакет UDoctor (xxxxxx) теперь доступен для установки. (Исправляется пользователем), чтобы узнать, как определить, доступен ли новый пакет UDoctor, а также как принять и установить новый пакет UDoctor.
ПРИМЕЧАНИЕ 1:
При выполнении модернизации (NDU) операционной среды Unity любые изменения, внесенные пакетом UDoctor, будут перезаписаны. Это означает, что, когда исправление программного обеспечения станет доступно в новом выпуске операционной среды Unity, можно будет выполнить стандартное бесперебойное обновление без дополнительных действий.
ПРИМЕЧАНИЕ 2:
Невозможно переопределить процесс инвентаризации/отправки и принудительно отправить пакет UDoctor в какую-либо конкретную систему Unity. Процесс инвентаризации и отправки выполняется еженедельно. Для заказчиков, которым исправление требуется быстрее, правильным решением является модернизация операционной среды Unity до версии 5.3.1.0.5.008 (5.3 SP1). Кроме того, заказчики могут использовать другие способы временного решения, перечисленные выше.