PowerProtect Data Manager - SQL Server Backups Complete With Unknown Status In The PPDM UI. Errors ABA0010: & ABA0017

Summary: Connection issue due to "sqlite3.OperationalError: database is locked" error on AgentService. This was because any operation on copies DB was taking lots of time as DB size with 3.65 GB. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Symptoms found in the logs:
File "DataStore\CopiesManager.py", line 251, in markCopiesAsDeleted

File "DataStore\RecordStore.py", line 146, in setFieldById

File "DataStore\SQLitedb.py", line 616, in updateColumn

sqlite3.OperationalError: database is locked

 

Cause

Database lock issue.

 

Resolution

Affected versions: 19.13 or below

Fixed Version: Database locking issue fixed in 19.14

Workaround: Contact Dell PowerProtect Data Manager to arrange for the Engineering team to produce a cleanup script to clean copies DB.
Article Properties
Article Number: 000218499
Article Type: Solution
Last Modified: 17 Oct 2023
Version:  1
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