NetWorker: Dati non disponibili a causa di problemi RabbitMQ su Windows Backup Server

Summary: Dati non disponibili a causa di problemi rabbitMQ sul backup server.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Il software del server NetWorker è installato su un server Microsoft Windows.
  • Dopo un recente aggiornamento del server NetWorker, vengono avviati i servizi; Tuttavia, nsrwatch e NetWorker Management Console (NMC) non riescono a visualizzare eventuali backup e l'avvio manuale dei backup non riesce.
  • La finestra degli avvisi NMC e il report NMC gstd.raw:
Linux: /opt/lgtonmc/logs/gstd.raw
Windows: C:\Program Files\EMC NetWorker\Management\GST\logs\gstd.raw

ERROR generated: "Message bus unable to open socket connection to host 'BACKUP-SRV' on port 5672: a socket error occurred" in file "D:/views/nw/19.8/nsrwebui/modules/nsm/gstnsm.c" line #11364

NetWorker: Come utilizzare nsr_render_log (in inglese)

  • La porta 5672 o 5671 non è in ascolto sul server NetWorker:
nsrports -t localhost -p PORT
netstat -ano | findstr PORT

NOTA: La porta 5672 è la porta legacy non SSL. La porta 5671 viene utilizzata per SSL. In NetWorker 19.7.x e versioni successive, la porta 5672 è disabilitata e il traffico rabbitmq viene inviato sulla porta 5671.
  • Eseguire il comando per avviare il server rabbitmq e questo era l'output:
Configuring logger redirection
Logger - error: {removed_failing_handler,rabbit_log}
13:46:52.589 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] Supervisor inet_gethost_native_sup had child at module inet_gethost_native at <0.206.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.589 [error] gen_server inet_gethost_native_sup terminated with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] CRASH REPORT Process inet_gethost_native_sup with 0 neighbours exited with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in gen_server:handle_common_reply/8 line 805
13:46:52.589 [error] Supervisor kernel_safe_sup had child inet_gethost_native_sup started with {inet_gethost_native,start_link,undefined} at <0.205.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.605 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.636 [error] 

13:46:52.636 [error] BOOT FAILED
BOOT FAILED
13:46:52.636 [error] ===========
===========
13:46:52.636 [error] ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
13:46:52.636 [error] 

13:46:53.647 [error] Supervisor rabbit_prelaunch_sup had child prelaunch started with rabbit_prelaunch:run_prelaunch_first_phase() at undefined exit with reason {epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}} in context start_error
13:46:53.647 [error] CRASH REPORT Process <0.151.0> with 0 neighbours exited with reason: {{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}} in application_master:init/4 line 138
{"Kernel pid terminated",application_controller,"{application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,\"BACKUP-SRV\",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}}}"}
Kernel pid terminated (application_controller) ({application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost

Crash dump is being written to: erl_crash.dump...done

Cause

Questo problema può verificarsi quando esiste un file non corretto o una directory denominata "program" nella radice del volume in cui è installato NetWorker. Questo file o directory potrebbe essere nascosto.

Resolution

Identificare se un file o una directory denominata "program" esiste nella radice di qualsiasi volume. In tal caso, eliminare o rinominare il file o la directory:
  1. Aprire un prompt dei comandi utilizzando Esegui come amministratore.
  2. Passare alla radice del volume.
Esempio:
cd D:\
  1. Eseguire il comando seguente per visualizzare gli object, inclusi gli object nascosti.
dir /a
  1. Se viene trovato un "Programma", eliminare o rinominare l'object.
  2. Ripetere i passaggi da 1 a 4 per tutti gli altri volumi o lettere di unità.
  3. Riavviare il servizio
net stop nsrexecd /y
net start nsrd
Se NMC è installato sullo stesso sistema:
net start gstd
  1. Riavviare l'host alla successiva opportunità.

Affected Products

Data Protection, NetWorker Family, NetWorker, NetWorker Management Console

Products

NetWorker Management Console
Article Properties
Article Number: 000220828
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.