Data Domain: volume sharing across multiple NetWorker Datazone can cause Data Loss.
Summary: Data is deleted from DD Boost devices if "More than one NetWorker Servers" seeing the same devices on the same Data Domain.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Data is deleted from DD Boost devices if "More than one NetWorker Servers" seeing the same devices on the same Data Domain.
Sharing of volumes is performed, but not limited to the following cases.
Sharing of volumes is performed, but not limited to the following cases.
- NetWorker server is migrated or rebuilt.
- When Save sets of a client must be scanned and restored on another Data Zone.
- Any DR Drill where the Data Zone backups are restored on the DR site NetWorker Server
WARNING: Sharing of DDboost/Disk volumes between Datazones (Two or More different NetWorker Servers) is NOT Supported.
This can lead to Data Loss!
This can lead to Data Loss!
Cause
NetWorker purges data through "nsrim -X" by checking what data is on the device, then checking what is in the Media Database, and if it is missing in the media database, NetWorker deletes the data.
Two devices pointing (Same Volume of Two different NetWorker servers) to the same old DD mtree, followed by nsrim "recover space" on the second NetWorker Server cleans up save sets on that mtree which were not in its Media Database.
This is documented product behavior.
Is run the "recover space" operation when running a nsrim task.
Two devices pointing (Same Volume of Two different NetWorker servers) to the same old DD mtree, followed by nsrim "recover space" on the second NetWorker Server cleans up save sets on that mtree which were not in its Media Database.
This is documented product behavior.
nsrstage -C -V <vol name>
Is run the "recover space" operation when running a nsrim task.
WARNING: Keeping the volumes in Read-Only will not help. The data will still be deleted.
Even a tough "Scan Needed Flag" prevents the deletion. This is still not supported.
Even a tough "Scan Needed Flag" prevents the deletion. This is still not supported.
Resolution
WARNING: Do not recommend any Customers share Disk/DDBoost volumes between NetWorker servers.
This is not Supported and can lead to a Data Loss situation.
This is not Supported and can lead to a Data Loss situation.
Additional Information
Engineering Escalations
https://esc.avamar.com/show_bug.cgi?id=35650
https://bugs.avamar.com/show_bug.cgi?id=305942
https://esc.avamar.com/show_bug.cgi?id=37201
https://esc.avamar.com/show_bug.cgi?id=35650
https://bugs.avamar.com/show_bug.cgi?id=305942
https://esc.avamar.com/show_bug.cgi?id=37201
Article Properties
Article Number: 000224754
Article Type: Solution
Last Modified: 09 Oct 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.