La condivisione di volumi DD in più datazone NetWorker può causare la perdita di dati.

Summary: I dati vengono eliminati dai dispositivi DD Boost se "più di un server NetWorker" rileva gli stessi dispositivi sullo stesso Data Domain.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I dati vengono eliminati dai dispositivi DD Boost se "più di un server NetWorker" rileva gli stessi dispositivi sullo stesso Data Domain.

La condivisione dei volumi viene eseguita, ma non solo, nei seguenti casi.
  1. Il server NetWorker viene migrato o ricostruito.
  2. Quando: I saveset di un client devono essere analizzati e ripristinati in un'altra datazone.
  3. Qualsiasi esercitazione DR in cui vengono ripristinati i backup delle datazone sul sito di DR NetWorker Server
 
AVVERTENZA: La condivisione di volumi DDboost/disco tra datazone (due o più server NetWorker diversi) NON è supportata.
Questo può portare alla perdita di dati!

Cause

NetWorker elimina i dati tramite "nsrim -X"controllando quali dati sono presenti sul dispositivo, quindi controllando cosa sono presenti nel database dei supporti e, se mancano nel database dei supporti, NetWorker elimina i dati.

Due dispositivi che puntano (stesso volume di due diversi server NetWorker) allo stesso vecchio MTree DD, seguiti da nsrim "recover space" sul secondo server NetWorker per pulire i saveset su tale MTree che non erano nel relativo database dei supporti. 


Si tratta di un comportamento del prodotto documentato.
nsrstage -C -V <vol name>

Esegue l'operazione "recover space" quando si esegue un attività nsrim.
 
AVVERTENZA: Mantenere i volumi in modalità read-only non è di aiuto. I dati verranno comunque cancellati.
Anche un forte "Scan Needed Flag" impedisce l'eliminazione. Questa operazione non è ancora supportata.

Resolution

AVVERTENZA: Si sconsiglia ai clienti di condividere volumi Disk/DDBoost tra i server NetWorker. 
Questa operazione non è supportata e può causare una perdita di dati.

Additional Information

Escalation tecniche
https://esc.avamar.com/show_bug.cgi?id=35650
https://bugs.avamar.com/show_bug.cgi?id=305942
https://esc.avamar.com/show_bug.cgi?id=37201

Affected Products

Data Protection
Article Properties
Article Number: 000224754
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.