Dell Precision Intel Graphics Driver Installer Takes Long to Launch

Summary: Have trouble with the Dell Precision workstation Intel Graphics Driver Installer taking a long time to launch? Discover how to troubleshoot and resolve performance issues efficiently.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 

Under the following system configuration situation, the Intel Graphics Driver version 31.0.101.5382 installer(Intel-UHD-GraphicsDriver_Y85G9_WIN64_31.0.101.5382_A08.exe) takes a long time from clicking the INSTALL to the following Begin installation appearing under Windows 11 OS.

  • The Security Intelligence version of Windows OS Virus & threat protection is 1.405.355.0

You can check the version of Virus & Threat Protection: Open settings → Click Privacy & security → Click Windows Security → Click Virus & Threat Protection → Click Protection updates.

Windows Security

(Figure 1 - Windows Security)

Affected Platforms:

  • Precision 7780
  • Precision 7680
  • Precision 7770
  • Precision 7670
   

Cause

 

Windows Virus & threat prototyping takes to time to scan the newly added parts in graphic install the new version_1.415.102.0 and newer versions can resolve the issue.

  

Resolution

 

To solve this issue, you can follow the below two options to update the Security Intelligence version to 1.415.102.0 or above versions.

Option 1 - Update Virus & threat protection version in system settings:

  1. Open Settings
  2. On the left plane, click Privacy & security
  3. Click Windows Security
  4. Then click Virus & threat protection
  5. Click Protection updates

    Windows Security

    (Figure 2 - Windows Security)

  6. Click Check for updates and wait for the update to complete

    Windows Security

    (Figure 3 - Windows Security)

Option 2 - Windows Update:

  1. Open Settings
  2. Then click Windows Update
  3. Click Check for updates and wait for the update to complete

    Windows Update

    (Figure 4 - Windows Update)

 

Follow your L2 escalation path to your TL if the customer is not happy with the resolution as a Customer Experience (CE) failure.

If the issue continues, then follow your escalation path through your L2/QL to the L3/REC team - as dictated by the system's warranty.


Back to Top

 

Affected Products

Precision 7670, Precision 7680, Precision 7770, Precision 7780
Article Properties
Article Number: 000227473
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.