Performance data not being collected in Unisphere for PowerMax 10.1

Summary: Performance data not being collected in Unisphere for PowerMax 10.1

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unisphere performance data on Windows host will not collect data, ports 8088 and 8089 will not stay listening from netstat.

The storstpd daemon could not send the processed performance data file DCF to the Postgres database via the default port 8088 and port 8089

storsptd.log:

Aug-19 7:55:14.271 pdsSockConnect #2377 : connect() failed: [fd=1820] [WSA code: 10061 - No connection could be made because the target machine actively refused it.]
<Error> [4084 dcfSpaSender] Aug-19 7:55:14.272 pdsIpcClientConnInit #1782 : Unable to establish client connection [pdsSockSocket()/pdsSockConnect() failed], nRc= 700004019
<Error> [4084 dcfSpaSender] Aug-19 7:55:14.272 : [sendFile()] TID: 912 SID: unable to connect to server: on port: 8088.
<Warn > [4084 dcfSpaSender] Aug-19 7:55:14.272 : [dcfSpaSender()] TID: 912 error processing file: 20240818_1300_000_F.dcf.gz.

Postgres logs show database system was interrupted and regularly starting up:

2024-08-12 11:57:38 GMT:127.0.0.1(59537):[unknown]@[unknown]:[6480]:LOG:  could not receive data from client: An existing connection was forcibly closed by the remote host.

No errors logged in the SMAS & RUN logs to show that the required ports are in use by other processes\applications:

Error [em.spa.SPA] (EJB default - 4) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0):Address already in use: JVM_Bind.

  • No FSCK errors or IO errors reported in the system event viewer
  • No network related issues with ports 8088 or 8089.

Cause

This is a known issue in Unisphere for PowerMax v10.1 where the storstpd daemon stops sending dcf files due to a situation where there are excessive alerts. 

Resolution

Workaround:
 

Change settings from true to false in the following 2 ejb-jar.xml files in the Unisphere install dir:

  1. install_dir/SMAS/jboss/domain/deploy/domain-symm.ear/domain-symm-ejb.jar/META-INF/ejb-jar.xml
  2. install_dir/SMAS/jboss/domain/deploy0/domain-symm0.ear/domain-symm-ejb.jar/META-INF/ejb-jar.xml


The setting is here:


<ejb-class>com.emc.em.domain.symmetrix.alert.SymmAutoClearAlertService</ejb-class>
<env-entry>
<env-entry-name>autoClearAlertsEnabled</env-entry-name>
<env-entry-type>java.lang.Boolean</env-entry-type>
<env-entry-value>true</env-entry-value>
</env-entry>


Change true to false and save the files.

Restart SMAS (don't reboot as changes will be lost).

 

 





















This Issue is permanently fixed in Unisphere for PowerMax v10.2.

Affected Products

Unisphere for PowerMax
Article Properties
Article Number: 000228313
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  3
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