NetWorker : Filesystem Backup failing with 7184:savefs: nothing to save

Summary: Filesystem Backup failing with 7184:savefs: nothing to save & sometimes stuck in Savefs only.

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Symptoms

Filesystem Backup Fails with below Error message:

7184:savefs: nothing to save
savefs <Client_name>: failed.


From the NetWorker Management Console (NMC), go to Monitoring tab > right-click particular Workflow > Show details > Failed section > Double-click Failed section > Get full log. 

Cause

  • When Newly Client is Onboarded
  • Client is not installed properly or nor properly updated with Aliases in the client details.
  • Manually someone has changed the client Configuration.
  • Savefs getting stuck & backup not proceeding further.

Resolution

Resolution : 

->Go to Administrator command prompt of the particular client failing.
->Run the below Command :
>>nsradmin -p nsrexecd ( It will prompt you to the nsradmin console)
>>Run p type: nsrla ( It will display output as below & you will get the correct Client name)

nsradmin>                         type: NSRLA;
                        name: <Client_name>;
              nsrmmd version: ;
             nsrsnmd version: ;
          Multi-subnet state: Disabled;
                   TCP Retry: 5;
NW instance info operations: ;
       NW instance info file: ;
          installed products: ;
                auth methods: "0.0.0.0/0,nsrauth";
           max auth attempts: 8;
        connection encrypted: Disabled;
                 module type: ;
              module version: ;
               administrator: No privilege to view administrator list;
                        arch: Windows Server 2022 Standard;
                 kernel arch: AMD_X8664;
                    CPU type: AMD_X8664;
                machine type: server;
                          OS: Windows Server 2022 Standard 10.0;
           NetWorker version: 19.8.0.3.Build.99;
              client OS type: Windows NT Server on Intel;
                        CPUs: 2;
             client timezone: AUS Eastern Daylight Time;
                     MB used: 20205;
                  IP address: 10.100.245.147;
nsradmin>
Nsradmin test PASSED
 
NetWorker Client name:  <Client_name>
 
NetWorker version:  "EMC NetWorker 19.8.0.3.Build.99 "

>> then quit it by just entering q & get out of the console.

Once you have the Networker Client name follow the below : 

->From the NetWorker Management Console (NMC), go to Protection tab 
->Then in the Clients column Search for that dedicated Failed client
->Then Right click on that client name & open the client properties
->Then go to Globals (1 of 2) , Check in that in the Aliases section & add the Networker Client name with all 3 pointers (i.e, Shortname, FQDN & IP).
->After updating the client details, kindly trigger the Full Backup as its a newly On boarded client & it will take Full Backup for the First time.

Please find below snip for the same:
>In the below we can find only two Aliases are added , one with the short name and more with the client name  
NetWorker Management Console ->Protection tab  

>>Here we have added the Networker Client name which will be different from the client’s name (domain will be different) 
 client properties screen 

>>Post triggering the backup will be get Successfully Completed.
 backup Successfully Completed screen 

Additional Information

Article Properties
Article Number: 000285458
Article Type: Solution
Last Modified: 18 Feb 2025
Version:  1
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