Dell Monitor USB-C Port Displays No Video

Summary: Learn about what to do if the USB-C port of a Dell monitor displays no video when connected to a desktop or laptop.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The USB-C port of a Dell C1422H, Dell P1424H, or Dell Pro 14 Plus Portable Monitor P1425 may not display video when connected to a computer.

Affected Platforms:

  • Dell C1422H
  • Dell P1424H
  • Dell Pro 14 Plus Portable Monitor P1425

Cause

The device that is connected to the monitor causes this problem. The USB-C port must support DisplayPort Alt Mode (DP Alt Mode), or a Thunderbolt port must be used. If the USB-C port only supports data or power delivery, no video is seen.

This may also be caused by using a USB-C to DisplayPort (DP) cable or USB-C to HDMI cable. Only a USB-C to USB-C cable may be used to display video using USB-C.

Resolution

Use a Thunderbolt port or a USB-C port that supports DP Alt Mode. If neither of these are present, use a different monitor input type.

A Thunderbolt USB-C port or a DisplayPort USB-C port on a computer can both support DP Alt Mode.
Thunderbolt USB-C and DisplayPort USB-C support DP Alt Mode

USB 2.0 and SuperSpeed USB ports on a computer do not support DP Alt Mode.
USB 2.0 and SuperSpeed USB ports do not support DP Alt Mode 

Note: If the USB-C port is unmarked, check your computer’s manual for more information about if DP Alt Mode is supported.

Affected Products

Dell C1422H, Dell P1424H, Dell Pro 14 Plus Portable Monitor P1425
Article Properties
Article Number: 000326500
Article Type: Solution
Last Modified: 15 Sep 2025
Version:  4
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