PowerFlex 3.6: Gateway Encounters Java Heap Space Error
Summary: The PowerFlex Gateway service encounters Java heap space errors during multiple Application Programming Interface (API) calls.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
PowerFlex Gateway version 3.6.6
PowerFlex Gateway scaleio.log may show the following:
2025-10-16 16:45:24,322 [https-jsse-nio-443-exec-16] DEBUG o.s.web.servlet.DispatcherServlet - Failed to complete request: jakarta.servlet.ServletException: Handler processing failed: java.lang.OutOfMemoryError: Java heap space
PowerFlex Gateway Catalina logs may show the following:
15-Oct-2025 19:41:56.301 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Connector] failed to set property [sessionCacheSize] to [2000]
Impact
PowerFlex API calls may fail to be processed.
Cause
Excessive memory consumption causes this error in the SSL session cache.
This occurred because the javax.net.ssl.sessionCacheSize system property was not correctly applied.
In the server.xml configuration, the attribute sessionCacheSize="2000" was incorrectly placed inside the <Connector> element.
Tomcat 10 ignores this property when defined there, resulting in unbounded SSL session growth, and an eventual OutOfMemoryError.
Resolution
- Connect to the PowerFlex Gateway server.
- Modify the file
/opt/emc/scaleio/gateway/conf/server.xml
Within the server.xml file, move the configuration setting:
sessionCacheSize="2000"
- To the bottom but within the <
SSLHostConfig> block - Save the file.
- Restart the PowerFlex Gateway service.
systemctl restart scaleio-gateway
Article Properties
Article Number: 000388358
Article Type: Solution
Last Modified: 20 Nov 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.