Data Domain Management Center Reboots Hourly After Upgrade
Resumen: The system reboots spontaneously approximately every hour after upgrading PowerProtect DD Management Center (DDMC). This happens due to an issue with the docker process identifier (PID) run file. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
- After the upgrade, the DDMC reboots on an almost hourly cadence.
- There are no obvious messages in kern.info or messages.engineering to indicate why the system was rebooted
- Log messages similar to the below are present in /ddr/var/log/debug/docker/psm.log:
01/31 10:16:27.951 ERROR: run_cmd: stderr: None 01/31 10:16:27.951 ERROR: run_cmd: stdout: b'Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n'
Causa
This is a rare situation where docker was ungracefully shut down and the PID file (var/run/docker.pid) is not correctly cleared. Docker cannot start when there is an existing PID file. This is expected behavior.
Resolución
Due to the system rebooting ungracefully, the mechanism that removes the stale PID file never runs. After the DDMC reboots, if you initiate a manual reboot of the DDMC, this should stop the reboot loop.
If not, contact Dell Support and an engineer can manually remove the docker PID file from the DDMC in bash:
If not, contact Dell Support and an engineer can manually remove the docker PID file from the DDMC in bash:
# rm /var/run/docker.pid
Propiedades del artículo
Número del artículo: 000221727
Tipo de artículo: Solution
Última modificación: 13 feb 2024
Versión: 1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.