O Data Domain Management Center é reinicializado de hora em hora após o upgrade

Resumen: O sistema reinicializa espontaneamente aproximadamente a cada hora após o upgrade do PowerProtect DD Management Center (DDMC). Isso acontece devido a um problema com o arquivo de execução do identificador de processo do docker (PID). ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

  • Após o upgrade, o DDMC é reinicializado em uma cadência de quase uma hora.
  • Não há mensagens óbvias em kern.info ou messages.engineering para indicar por que o sistema foi reinicializado
  • Mensagens de registro semelhantes às abaixo estão presentes em /ddr/var/log/debug/docker/psm.log:
01/31 10:16:27.951 ERROR: run_cmd: stderr: None
01/31 10:16:27.951 ERROR: run_cmd: stdout: b'Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n'

Causa

Essa é uma situação rara em que o docker foi desligado abruptamente e o arquivo PID (var/run/docker.pid) não é removido corretamente. Não é possível iniciar o Docker quando há um arquivo PID existente. Esse é um comportamento esperado.

Resolución

Devido à reinicialização abrupta do sistema, o mecanismo que remove o arquivo PID obsoleto nunca é executado. Após a reinicialização do DDMC, se você iniciar uma reinicialização manual do DDMC, o loop de reinicialização deverá interrompê-lo.

Caso contrário, entre em contato com o Suporte Dell e um engenheiro poderá remover manualmente o arquivo PID do docker do DDMC no bash:
# rm /var/run/docker.pid
Propiedades del artículo
Número del artículo: 000221727
Tipo de artículo: Solution
Última modificación: 13 feb 2024
Versión:  1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.