Dell EMC Unity : dans certaines situations où l’espace est insuffisant pour le système de fichiers, la mise à niveau vers la version 5.1 du code peut échouer (corrigible par l’utilisateur)

Sommaire: Dans certaines situations où l’espace est insuffisant, une mise à niveau vers la version 5.1 peut déclencher des problèmes de cache et des redémarrages répétés du SP.

Cet article s’applique à Cet article ne s’applique pas à Cet article n’est lié à aucun produit spécifique. Toutes les versions de produits ne sont pas identifiées dans cet article.

Symptômes

Après la mise à niveau vers la version 5.1, les SP ne démarrent pas complètement ou ils peuvent effectuer des redémarrages répétés.  Ils peuvent présenter des problèmes de perte de cache.

Cause

Ce problème est dû au fait qu’un système de fichiers n’a plus d’espace inode et ne peut pas créer l’« OrphanDir », une nouvelle fonctionnalité dans la version 5.1.  La création d’une OrphanDir utilise 13 inodes. Si un système de fichiers ne dispose pas de 13 inodes disponibles, la création échoue et le système de fichiers ne se monte pas, provoquant un fonctionnement inattendu du SP.

Résolution

Correctif :
Un correctif est en cours de création.  Pour plus d’informations, consultez cet article de la base de connaissances.

Solution de contournement :
Avant la mise à niveau, un système Unity peut être vérifié pour s’assurer qu’il existe des inodes appropriés disponibles.  Reportez-vous à la section « Informations supplémentaires » ci-dessous pour voir les commandes à utiliser pour rechercher l’espace inode disponible avant la mise à niveau.

Si un système de fichiers se trouve dans cette condition, l’extension du système de fichiers corrige la condition et ajoute suffisamment d’espace pour permettre la mise à niveau. 
  • Une extension du système de fichiers d’au moins 10 Go devrait être suffisante.  
  • Une fois le système de fichiers étendu, créez un fichier à l’intérieur.  Cela permet de s’assurer que la tranche d’inode est ajoutée au système de fichiers.
Une fois que vous avez implémenté la solution de contournement, vérifiez à nouveau l’espace d’inode et assurez-vous qu’il est suffisant (au moins 13 inodes libres) avant de poursuivre la mise à niveau.

Renseignements supplémentaires

Pour vérifier l’existence de ce problème :

1. Exécutez la commande suivante dans une session shell sur votre système Unity :

svc_storagecheck -s | grep -A1 inodes

19:21:42 service@Unity spa:~/user# svc_storagecheck -s | grep -A1 inodes
1630610514: ADMIN: 6:  Filesystem      inodes         used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870913     2331376           93       2331283         0% /
--
1630610514: ADMIN: 6:  Filesystem      inodes         used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870916     1291504           16       1291488         0% /test1
--
1630610514: ADMIN: 6:  Filesystem     inodes          used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870920     771568            19        771549         0% /testfs2
--
1630610514: ADMIN: 6:  Filesystem     inodes          used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870922     771568            82        771486         0% /.etc


Un système Unity qui rencontre ce problème affiche un système de fichiers qui ressemble à celui-ci :

1630610514: ADMIN: 6:  Filesystem      inodes         used         avail   capacity Mounted on
1630610514: ADMIN: 6:   536870916     1291504      1291504             0       100% /test1


Notez qu’il n’y a pas d’inodes disponibles et que le système de fichiers est à 100 % de sa capacité d’inode.

Produits touchés

Dell EMC Unity
Propriétés de l’article
Numéro d’article: 000191205
Type d’article: Solution
Dernière modification: 11 mai 2026
Version:  9
Obtenez des réponses à vos questions auprès d’autre utilisateurs de Dell
Services de soutien
Vérifiez si votre appareil est couvert par les services de soutien.