NetWorker-modul for Microsoft: Kan ikke hente lagringssett under veiviser for ny klient for SQL-klynge – feil: Det henvises til objektet finnes ikke.

概要: Oppretting eller sikkerhetskopiering av SQL-klient mislykkes på grunn av manglende «Operate NetWorker»-rettigheter for SYSTEM-kontoen for SQL-noder.

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Ved hjelp av veiviseren for ny klient for å opprette en klient for SQL-klynge med windows server failover-klyngenavn – veiviseren får skjermbildet som viser lagre/db-er og gir feilmelding: 

"unable to retrieve save sets. (Kan ikke hente lagringssett. Se nsrsqlsv- og nsrnmsqlra-logger for mer informasjon. Error: Det henvises til objektet finnes ikke.»

NetWorker-serverens /nsr/logs/daemon.raw-rapporter:
nsrjobd SYSTEM critical User SYSTEM does not have the privileges required to start the requested job. The required privilege is: Operate NetWorker. The job requested to be started is: nsrsqlsv.
NetWorker: Slik bruker du nsr_render_log

原因

Systemkontoen til klyngenoden har ikke «Operate NetWorker»-rettigheter og kan ikke starte nsrsqlsv.

解決方法

SYSTEM@node_client_name må legges til i NetWorker-brukergruppen Operatorer. Denne endringen kan brukes fra NetWorker Management Console (NMC) eller fra NetWorker Web User Interface (NWUI). Handlingsplanen er den samme for begge brukergrensesnittene.

1. Logg på NMC eller NWUI med NetWorker Administrator-kontoen, eller en konto med rettigheter til "Application Administrator" og "Security Administrator".
2. Gå til serverbrukergrupper>.
3. Åpne operatørbrukergruppen.
4. I feltet Users (Brukere) legger du til følgende oppføring ved hjelp av nodeklientnavnene til SQL-klyngen:
SYSTEM@node1_client_name
SYSTEM@node2_client_name
 
MERK: Du kan også legge til SYSTEM@* eller *@* avhengig av hvordan du vil delegere NetWorker-tillatelser.

対象製品

NetWorker Module for Microsoft

製品

NetWorker, NetWorker Management Console, NetWorker Module for Microsoft
文書のプロパティ
文書番号: 000055234
文書の種類: Solution
最終更新: 29 9月 2023
バージョン:  3
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。