NetWorker Module for Microsoft: Det går inte att hämta sparuppsättningar under New Client Wizard for SQL Cluster – Fel: Refererade objekt finns inte.

概要: Det går inte att skapa eller säkerhetskopiera SQL-klienten på grund av att behörigheten "Operate NetWorker" saknas för SQL-nodsystemets SYSTEM-konto.

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Med hjälp av guiden för ny klient för att skapa en klient för SQL-kluster med Windows Server failover-klusternamn – guiden får den skärm som visar sparuppsättningar/db och ger fel: 

"unable to retrieve save sets. Mer information finns i nsrsqlsv- och nsrnmsqlra-loggarna. Fel: Referenced object does not exist."

NetWorker-serverns rapporter /nsr/logs/daemon.raw:
nsrjobd SYSTEM critical User SYSTEM does not have the privileges required to start the requested job. The required privilege is: Operate NetWorker. The job requested to be started is: nsrsqlsv.
NetWorker: Använda nsr_render_log

原因

Klusternodens SYSTEM-konto har inte behörigheten "Operate NetWorker" och kan inte starta nsrsqlsv.

解決方法

SYSTEM@node_client_name måste läggas till i NetWorker User Group "Operators". Den här ändringen kan tillämpas från NetWorker Management Console (NMC) eller från NetWorker-webbanvändargränssnittet (NWUI). Åtgärdsplanen är densamma för båda användargränssnitten.

1. Logga in på NMC eller NWUI med NetWorker-administratörskontot, eller ett konto med behörigheten "Application Administrator" och "Security Administrator".
2. Gå till Server-User>Groups.
3. Öppna användargruppen Operatorer.
4. I fältet Users lägger du till följande post med nodklientnamnen för SQL-klustret:
SYSTEM@node1_client_name
SYSTEM@node2_client_name
 
Obs! Du kan även lägga till SYSTEM@* eller *@* beroende på hur du vill delegera NetWorker-behörigheter.

対象製品

NetWorker Module for Microsoft

製品

NetWorker, NetWorker Management Console, NetWorker Module for Microsoft
文書のプロパティ
文書番号: 000055234
文書の種類: Solution
最終更新: 29 9月 2023
バージョン:  3
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。