NetWorker Module for Microsoft: SQL-klusterin uuden client wizard -toiminnon aikana ei voi hakea tallennusjoukkoja - virhe: Viitattu objekti ei ole olemassa.

概要: SQL-työasemien luonti tai varmuuskopiointi epäonnistuu, koska SQL-solmujen JÄRJESTELMÄtililtä puuttuu Operate NetWorker -oikeudet.

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Luo new client wizard -toiminnolla työasema SQL-klusterille, jossa on Windows Serverin vikasietoklusterin nimi: ohjattu toiminto tuo näkyviin näytön, jossa näkyvät tallennussarjat/tietokantatiedostot, ja näyttää virheen: 

unable to retrieve save sets. Lisätietoja on nsrsqlsv- ja nsrnmsqlra-lokeissa. Error: Viitattu objekti ei ole olemassa.

NetWorker-palvelimen /nsr/logs/daemon.raw-raportit:
nsrjobd SYSTEM critical User SYSTEM does not have the privileges required to start the requested job. The required privilege is: Operate NetWorker. The job requested to be started is: nsrsqlsv.
NetWorker: nsr_render_log käyttäminen

原因

Klusterisolmujen SYSTEM-tilillä ei ole Operate NetWorker -oikeuksia eikä se pysty käynnistämään nsrsqlsv:tä.

解決方法

SYSTEM@node_client_name on lisättävä NetWorker User Groupin Operaattorit-kohtaan. Muutoksen voi tehdä NetWorker Management Consolessa (NMC) tai NetWorker-verkkokäyttöliittymässä (NWUI). Toimintasuunnitelma on sama molemmissa käyttöliittymissä.

1. Kirjaudu NMC- tai NWUI-liittymään NetWorker-järjestelmänvalvojan tilillä tai tilillä, jolla on Application Administrator- ja Security Administrator -oikeudet.
2. Siirry kohtaan Server-User>Groups.
3. Avaa Operaattorit-käyttäjäryhmä.
4. Lisää Users (Käyttäjät) -kenttään seuraava merkintä sql-klusterin solmutyöasemien nimillä:
SYSTEM@node1_client_name
SYSTEM@node2_client_name
 
HUOMAUTUS: Voit myös lisätä SYSTEM@* tai *@* sen mukaan, miten haluat delegoida NetWorker-käyttöoikeudet.

対象製品

NetWorker Module for Microsoft

製品

NetWorker, NetWorker Management Console, NetWorker Module for Microsoft
文書のプロパティ
文書番号: 000055234
文書の種類: Solution
最終更新: 29 9月 2023
バージョン:  3
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。