NVP vProxy : Échec de la sauvegarde de la machine virtuelle avec « le snapshot a déjà été supprimé ou n’a pas été entièrement créé »
Resumo: Échec de la sauvegarde de la machine virtuelle avec « le snapshot a déjà été supprimé ou n’a pas été entièrement créé »
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
- Les sauvegardes de machines virtuelles effectuées avec l’appliance NVP vProxy signalent l’erreur suivante :
YYYY-MM-DDTHH:mm:SSZ ERROR: Request to remove snapshot 'snapshot-#####' on VM 'VM_NAME' was rejected by vCenter 'VCENTER_NAME': ServerFaultCode: The object 'vim.vm.Snapshot:snapshot-#####' has already been deleted or has not been completely created
Causa
Il y avait d’anciens fichiers de snapshot dans le datastore pour cette machine virtuelle.
Resolução
L’utilitaire ProxyHC peut être utilisé pour nettoyer les disques et les snapshots restants.
Pour effectuer un nettoyage manuel dans VMware, procédez comme suit :
Au début des sauvegardes de machine virtuelle, le vProxy demande au vCenter de créer un snapshot pour la machine virtuelle. Une demande est envoyée à la fin de la sauvegarde pour supprimer le snapshot. Le serveur vCenter crée, gère et supprime les fichiers de snapshot. Si ce problème persiste ou qu’une erreur se produit au cours de l’une des étapes ci-dessus, contactez le support VMware pour obtenir de l’aide.
Pour effectuer un nettoyage manuel dans VMware, procédez comme suit :
- Connectez-vous au client Web vSphere.
- Cliquez avec le bouton droit de la souris sur la machine virtuelle et sélectionnez Snapshots-> Delete All Snapshots.
- Cliquez avec le bouton droit de la souris sur la machine virtuelle et sélectionnez Snapshots-Consolidate>.
- Sélectionnez l’onglet Datastores et accédez au répertoire de la machine virtuelle, puis recherchez les fichiers de snapshot. Si des fichiers de snapshot résident ici, supprimez-les.
- Si aucun snapshot n’est trouvé, mais que le problème persiste, essayez de créer un snapshot à partir de VMware.
NOTE:Si la machine virtuelle effectue des sauvegardes cohérentes avec les applications (MSVMAPPAGENT), effectuez un snapshot mis en veille ; sinon, effectuez un snapshot non mis en veille.
- Répétez les étapes 2 à 4 pour vous assurer que les fichiers de snapshot sont supprimés.
- Exécutez une sauvegarde.
Au début des sauvegardes de machine virtuelle, le vProxy demande au vCenter de créer un snapshot pour la machine virtuelle. Une demande est envoyée à la fin de la sauvegarde pour supprimer le snapshot. Le serveur vCenter crée, gère et supprime les fichiers de snapshot. Si ce problème persiste ou qu’une erreur se produit au cours de l’une des étapes ci-dessus, contactez le support VMware pour obtenir de l’aide.
Produtos afetados
NetWorkerProdutos
NetWorkerPropriedades do artigo
Número do artigo: 000172495
Tipo de artigo: Solution
Último modificado: 28 mai. 2025
Versão: 4
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.