NVP-vProxy: VM-Backup schlägt fehl mit "Snapshot has already been deleted or has not been completely created" (Snapshot wurde bereits gelöscht oder wurde nicht vollständig erstellt)

Resumo: VM-Backup schlägt fehl mit "Snapshot has already been deleted or has not been completely created" (Snapshot wurde bereits gelöscht oder wurde nicht vollständig erstellt)

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

  • VM-Backups, die mit der NVP vProxy-Appliance durchgeführt wurden, melden den folgenden Fehler:
YYYY-MM-DDTHH:mm:SSZ ERROR: Request to remove snapshot 'snapshot-#####' on VM 'VM_NAME' was rejected by vCenter 'VCENTER_NAME': ServerFaultCode: The object 'vim.vm.Snapshot:snapshot-#####' has already been deleted or has not been completely created

Causa

Es gab alte Snapshot-Dateien im Datenspeicher für diese VM.

Resolução

Das ProxyHC-Dienstprogramm kann verwendet werden, um übrige Festplatten und Snapshots zu bereinigen. 

Um eine manuelle Bereinigung in VMware durchzuführen, führen Sie die folgenden Schritte aus:
  1. Melden Sie sich beim vSphere-Webclient an.
  2. Klicken Sie mit der rechten Maustaste auf die VM und wählen Sie Snapshots –> Alle Snapshots löschen aus.
  3. Klicken Sie mit der rechten Maustaste auf die VM und wählen Sie Snapshots-Consolidate> aus.
  4. Wählen Sie die Registerkarte Datastores aus und navigieren Sie zum Verzeichnis für die VM und suchen Sie nach Snapshot-Dateien. Wenn sich Snapshot-Dateien hier befinden, löschen Sie sie.
  5. Wenn keine Snapshots gefunden werden, aber das Problem weiterhin besteht, versuchen Sie, einen Snapshot von VMware zu erstellen.
HINWEIS:Wenn die VM anwendungskonsistente Backups (MSVMAPPAGENT) durchführt, führen Sie einen stillgelegten Snapshot aus. Andernfalls führen Sie einen nicht stillgelegten Snapshot durch.
  1. Wiederholen Sie die Schritte 2 bis 4, um sicherzustellen, dass die Snapshot-Dateien entfernt werden.
  2. Führen Sie ein Backup aus.

Zu Beginn der VM-Backups fordert der vProxy das vCenter auf, einen Snapshot für die VM zu erstellen. Am Ende des Backups wird eine Anforderung zum Entfernen des Snapshot gesendet. Der vCenter-Server erstellt, managt und löscht die Snapshot-Dateien. Wenn dieses Problem weiterhin besteht oder während eines der oben genannten Schritte ein Fehler auftritt, wenden Sie sich an den VMware-Support, um Unterstützung zu erhalten.

Produtos afetados

NetWorker

Produtos

NetWorker
Propriedades do artigo
Número do artigo: 000172495
Tipo de artigo: Solution
Último modificado: 28 mai. 2025
Versão:  4
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.