PowerProtect Data Manager 19.12 and earlier: High CPU usage by the Agent Service
摘要: High Central Processing Unit (CPU) usage by the Agent Service’s operating system (OS) process.
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症状
A host's operating system shows high CPU usage when running PowerProtect Data Manager 19.12 or earlier versions.
There are no symptoms visible in the logs, but the behavior occurs in the host's Task Manager application.
原因
There are two known causes for spiking CPU behavior:
- The tasks.db file must reload for each iteration. If it is large, each time this happens, it causes a spike in CPU consumption.
- Version 19.11 uses a lockbox Application Programming Interface (API) call for every GET session API call.
This lockbox API call consumes more CPU than normal. The polling for a GET session API runs every 30 s.
There is an unnecessary call in this request that tries to decrypt the password each time.
解决方案
Affected versions: This issue impacts v19.12 and earlier versions.
Workaround:
- Stop the Agent Service.
- Rename the tasks.db in C:\Program Files\DPSAPPS\AgentService\dbs\v1.
- Restart the Agent Service.
Fixed version: The issue is not present in v19.13 and later versions.
受影响的产品
PowerProtect Data Manager, PowerProtect Software文章属性
文章编号: 000212583
文章类型: Solution
上次修改时间: 06 10月 2025
版本: 3
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