NetWorker: Chyby RPC na zálohovacích zařízeních NetWorker DDBoost

摘要: Systém Data Domain s aktivní relací sleduje problémy s komunikací, díky nimž zařízení Data Domain přejdou do zastaralého stavu. I když neprodochází k zápisu, zachytí relaci, která nefunguje, a neuvolní informace o relaci použité z databáze správy médií. Všechna zařízení spojená se stejným fondem a uzlem úložiště nemohou přijmout žádnou další relaci. Dotčená zařízení nepřijímají žádnou úlohu zálohování nebo klonování, což má za následek chyby RPC. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

  • Všechny operace zálohování/klonování na serveru NetWorker zůstanou ve stavu Hung/Queued, jelikož zařízení DDBOOST byla ve stavu Unmounted a v protokolech akcí se zobrazí následující chyba: 
Nepodařilo se získat uživatelské jméno a heslo pro zařízení < název zařízeníDDBOOST>; Operace odeslání RPC se nezdařila. errno = Nefunkční svislá čára
 
  • Zálohování sady uložení se nezdařilo z důvodu neobnovitelných chyb je jednou z významných chybových zpráv.
  • Během zálohování se zařízení Data Domain odpojí, i když mezi softwarem NetWorker a Data Domain nedochází k žádným problémům s připojením.
  • Poškození v databázi úloh NetWorker, což vede k nekonzistenci mezi zálohovací aplikací NetWorker a databází úloh

原因

Chyby RPC na zálohovacích zařízeních Data Domain DDBOOST by měly být pravidelně sledovány a je třeba provést nápravnou akci, jinak úlohy zálohování/klonování zůstanou ve stavu čekání, a dokonce není k dispozici žádný zápis, že neschová nefunkční relaci, a neuvolní informace o relaci používané v databázi správy médií.

解决方案

Restartování služeb NetWorker Services lze provést v prvním případě a mohli jsme si všimnout, že k problému dochází znovu, jelikož základní chyby RPC na zařízeních DDBOOST stále přetrvávají. 

Hodnoty časového limitu v uzlech NetWorker Storage je nutné jemně vyladit podle doporučení prostředí NetWorker Backup a průvodce optimalizací zařízení NetWorker.

Na uzlu úložiště networkeru Linux nastavte podle následujících pokynů příslušné hodnoty časového limitu tcp Keep Alive, jak je znázorněno na obrázku.
1. Přepněte na root: sudo su -
2. Chcete-li upravit nastavení tcp_keepalive, spusťte následující příkazy:
# echo 700 > /proc/sys/net/ipv4/tcp_keepalive_time
# echo 10 > /proc/sys/net/ipv4/tcp_keepalive_intvl
# echo 20 > /proc/sys/net/ipv4/tcp_keepalive_probes
Na uzlu úložiště Networker systému Windows nastavte podle následujících pokynů příslušné hodnoty časového limitu tcp Keep Alive, jak je znázorněno na obrázku:
1. Před provedením změn zálohujte registr systému Windows.
2. Přejděte do složky "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters".
3. Vytvořte novou položku REG-DWORD s názvem "KeepAliveTime".
4. Zadejte hodnotu Decimal 900000 (15 minut).
5. Aby byla nová hodnota aktivní, je nutné restartovat počítač.

POZNÁMKA: Další ladění TCP je podrobně popsáno v příručce plánování optimalizace výkonu NetWorker, která je k dispozici prostřednictvím https://www.dell.com/support/home/product-support/product/networker/docs.

Po definování výše uvedených parametrů je nutné restartovat služby Storage Node NetWorker. Ujistěte se, že tyto hodnoty zůstávají konzistentní v rámci restartování uzlu úložiště NetWorker.

Veškeré nekonzistence v aplikaci NetWorker Backup Application ve vztahu k procesu nsrmmd na uzlu úložiště NetWorker je nutné eliminovat provedením níže uvedených kroků.

1. Zastavte služby NetWorker na zálohovacím serveru.

Linux: nsr_shutdown Windows
: net stop nsrexecd /y

2. Přejmenujte složky /nsr/res/jobsdb, /nsr/logs/daemon.raw a /nsr/tmp na serveru NetWorker.
3. Restartujte znovu službu NetWorker Services na zálohovacím serveru, která nyní znovu inicializovat operace ukládání NetWorker a nebudou zaznamenány žádné další resetování připojení RPC a hodnoty časového limitu nečinnosti.

Linux: Systemctl start Networker
Windows: net start nsrd

, pokud je na serveru NetWorker nainstalována konzole NMC: net start gstd

文章属性
文章编号: 000217738
文章类型: Solution
上次修改时间: 15 11月 2023
版本:  2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。