NetWorker. Ошибки RPC на устройствах резервного копирования NetWorker DDBoost

摘要: Data Domain с активной сессией наблюдает проблемы связи, которые делают устройства Data Domain устаревшими. Даже если запись не выполняется, она удерживает не работающий сеанс и не выпустит информацию о сессии, используемую из базы данных управления носителями. Все устройства, связанные с одинаковым пулом и узлом хранения данных, не могут принять больше сессий. затронутые устройства не принимают задание резервного копирования или клонирования, что приводит к ошибкам RPC. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

  • Все операции резервного копирования и клонирования на сервере NetWorker просто остаются в состоянии «Зависание/очередь», так как устройства DDBOOST были в состоянии «Unmounted» и в журналах действий отображается следующая ошибка: 
Не удалось получить имя пользователя и пароль для устройства ; Сбой операции отправки RPC; errno = поврежденная трубка
 
  • Сбой резервного копирования сохраняемого набора данных из-за неустранимых ошибок является одним из важных сообщений об ошибке.
  • Устройства Data Domain отключаются во время окна резервного копирования, хотя нет проблем с подключением между NetWorker и Data Domain.
  • Повреждение в базе данных заданий NetWorker приводит к несогласованности между приложением резервного копирования NetWorker и базой данных заданий

原因

Ошибки RPC на устройствах резервного копирования Data Domain DDBOOST должны периодически отслеживаться и корректироваться. В противном случае задачи резервного копирования/клонирования остаются в состоянии ожидания, даже ничего не записывающее, что содержит не работающий сеанс, и не высвобождает информацию о сессии, используемую из базы данных управления носителями.

解决方案

В первом случае можно перезапустить службы NetWorker, и можно заметить, что проблема снова возникает, так как базовые ошибки RPC на устройствах DDBOOST по-прежнему сохраняются. 

Значения тайм-аута на узлах хранения NetWorker должны быть точно настроены в соответствии с учетом требований среды резервного копирования NetWorker и руководства по оптимизации устройств NetWorker.

На узле хранения данных Linux Networker выполните следующие действия, чтобы задать соответствующие значения тайм-аута TCP Keep Alive, как показано на рисунке.
1. Переключиться на root: sudo su -
2. Для изменения параметров tcp_keepalive выполните следующие команды:
# echo 700 > /proc/sys/net/ipv4/tcp_keepalive_time
# echo 10 > /proc/sys/net/ipv4/tcp_keepalive_intvl
# echo 20 > /proc/sys/net/ipv4/tcp_keepalive_probes
На узле хранения Данных Windows Networker выполните следующие действия, чтобы задать соответствующие значения тайм-аута TCP Keep Alive, как показано ниже:
1. Перед внесением изменений создайте резервную копию реестра Windows.
2. Перейдите в папку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters.
3. Создайте новую запись REG-DWORD с именем KeepAliveTime.
4. Присвойте для него значение десятичное значение 900000 (15 минут).
5. Для активации нового значения требуется перезагрузка.

ПРИМЕЧАНИЕ. Дополнительная настройка TCP подробно описана в Руководстве по планированию оптимизации производительности NetWorker, доступном https://www.dell.com/support/home/product-support/product/networker/docs.

После определения указанных выше параметров необходимо перезапустить службы NetWorker узла хранения. Убедитесь, что эти значения остаются согласованными при перезапуске узла хранения NetWorker.

Кроме того, необходимо устранить любые несоответствия в приложении резервного копирования NetWorker в отношении процесса nsrmmd на узле хранения NetWorker, выполнив указанные ниже действия.

1. Остановите службы NetWorker на сервере резервного копирования.

Linux: nsr_shutdown
Windows: net stop nsrexecd /y

2. Переименуйте папки /nsr/res/jobsdb, /nsr/logs/daemon.raw и /nsr/tmp на сервере NetWorker.
3. Перезапустите NetWorker Services на сервере резервного копирования. Это приведет к повторной инициализации операций сохранения NetWorker и больше не будет отображаться никаких значений сброса соединения RPC и тайм-аута бездействия.

Linux: systemctl start networker
Windows: net start nsrd

, если NMC установлен на сервере NetWorker: net start gstd

文章属性
文章编号: 000217738
文章类型: Solution
上次修改时间: 15 11月 2023
版本:  2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。