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PowerStore Alerts: Port Link Failure

Summary: PowerStore Port failures due to Compatibility, Configuration, and Hardware issues.

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Article Content


Symptoms

When the PowerStore encounters a problem, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant solutions for these error alerts. If your problem is not resolved despite the solution that is provided, check the technical support contact options.

 

NOTE: Cannot find the information that you need? Let us know using the feedback form at the bottom of this article.
 
NOTE: Often the latest PowerStoreOS solves Port Link Failures. See PowerStore: How to download a new version of PowerStoreOS.

Cause

The cause for the alerts has been explained in the Resolution section.
 
NOTE: To check hardware and switch compatibility, see Section 1 "Get to Know PowerStore" in the PowerStore: Info Hub - Product Documentation & Videos

Resolution

Alert ID XMS_FEPORT_PORT_STATE_DOWN_IN_USE
Alert Text Port link is down
Error Code (0x00307404)
Cause
For FC and Ethernet ports:
  1. Configuration: Parameters set are incompatible with the hardware (switch or array-side). For example: Fixed speed settings on either side, FC SFP in Ethernet port on the switch side, and so on.
  2. Compatibility: SFPs of the cable are unable to negotiate to a common speed (for example: a 25G port is connected to a 10G switch).
  3. Hardware: Faulted SFP (if available), cable, switch SFP (if available), I/O Module failure(such as power failure).
  4. Node Reboots: A node reboot can trigger a port link down alert. This could also be a symptom of an unexpected system reboot.
Solution
  1. Configuration: Check and rectify the configuration on the array or switch side, by changing settings or hardware.
  2. Compatibility: Ensure that the hardware and the switch are compatible by checking capabilities and settings.
  3. Hardware: Identify and replace faulty hardware. Contact technical support for further assistance.   
  4. Node Reboots: Review the system alerts and events tabs for any messages that could indicate an unexpected node reboot.
    For guidance on how to identify node reboots, see PowerStore: Unexpected node reboots general article

This alert may be raised as a false positive in the following scenarios:
  • If there is a storage network configured but cable is not connected to the corresponding Ethernet port:
    • Scenario 1: The storage network configured on the port is not the last storage network on the cluster.
          Workaround: Tag the other network for replication first if the affected port is tagged for replication. Deleting the storage network clears the alert.
    • Scenario 2: The storage network configured on this port is the last storage network on the cluster. 
          Workaround: Contact technical support for them to delete the last storage network.
  • Scenario 3: No storage network is configured for a PowerStoreT Unified (with SDNAS), running with 3.x, with no cable connected to any of the first two ports on the 4-port card, then a false positive may be raised in rare cases. Contact technical support for assistance.
  • Scenario 4: The alert is raised on an FC port:
         Workaround: Contact technical support for a resolution to this issue.
Note: The PowerStore Manager has a port attribute to indicate if the port is FC or Ethernet.  
 

 

Alert ID XMS_FEPORT_PORT_STATE_LINK_SPEED_ASYMMETRIC
Alert Text Port link speeds in partner ports of the appliance do not match
Error Code (0x00307405)
Cause The port and its partner port are configured to different port speeds. 
Solution Ensure configuration settings (for example: port speed) for partner ports are identical as well. It is recommended that you always install components in pairs. If required, contact technical support for further assistance.
  

Article Properties


Affected Product

PowerStore

Last Published Date

08 Apr 2024

Version

12

Article Type

Solution