Dell Unity: Too many API requests from the CSI driver for Unity may cause SP panic or MGMT service down
Summary: Too many API requests from the CSI driver for the Dell Unity array may cause an SP to panic or MGMT service to remain down.
Symptoms
Too many API requests from the CSI driver for the Dell Unity array may cause an SP to panic or MGMT service to remain down.
Hosts are making continuous REST API calls to the Unity array, resulting in the management server being busy with thousands of calls.
Dell Unity MGMT issues occurring due to the high number of API calls.
Cause
Older versions of the CSM Operator (below version 1.7) and CSI Driver for Unity (below version 2.12) can generate too many API requests which may cause an SP to panic or MGMT service to remain down.
Related Fixes that reduce REST API calls:
- CSI Driver v2.12 - Disables Health Monitoring by default (Health monitoring, when enabled, floods the Array with REST API calls)
- CSM Operator v1.7 - Reduction in authentication API calls (from v1.6.1)
The new version disables Health Monitoring by default (Health monitoring, when enabled floods the Array with REST API calls)
Resolution
Workaround:
Restarting or failing over the MGMT Services to the other SP brings the MGMT services back online and available.
Fix:
Upgrade the CSI Driver for Unity and the CSM Operator to the following versions or above:
- CSI Driver v2.12
- CSM Operator v1.7
Documentation and links to software:
https://dell.github.io/csm-docs/v1/deployment/csmoperator/
https://dell.github.io/csm-docs/docs/
Release Notes for CSI Drivers
https://kubernetes-csi.github.io/docs/
Release Notes for CSM Operator:
https://dell.github.io/csm-docs/docs/release/
What's New release v1.7
What is Changed: 1415 - [FEATURE]: Unity consistency update to reduce the number of authentication API calls