Data Domain: Disks failing daily after upgrade to DDOS 8.3.0.0
Summary: Due to a software issue within DDOS (8.3.0.0), a daily disk failure is reported on external storage attached to systems running Protection Pool RAID (e.g DD6400)
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Symptoms
Applies to:
-
- PowerProtect Data Domain running Protection Pools RAID (SP-RAID)
- Current (SP-RAID) models: DD6400 | DD6410 | DM5500
- DDOS version 8.3.0.0
- PowerProtect Data Domain running Protection Pools RAID (SP-RAID)
Symptoms:
-
- Single disk failure is reported on attached storage ~24 hours after upgrade to DDOS 8.3.0.0.
- The first disk to fail is (usually) disk #1 in an attached shelf
- For example, disk 2.1
- Further single disk failures continue to be encountered on a daily (24 hours) basis.
- In the following example, we see 3x DAILY disk failures, reported over 3 days at the same time (~16:13).
- Single disk failure is reported on attached storage ~24 hours after upgrade to DDOS 8.3.0.0.
# alerts show current -------------- Post Time Object Message ------------------------ ------------------ ------------------------------------------------------------------------ Fri Feb 7 16:13:51 2025 Enclosure=2:Disk=1 EVT-STORAGE-00002: Unable to access a disk and the disk state is failed. Sat Feb 8 16:13:09 2025 Enclosure=2:Disk=2 EVT-STORAGE-00002: Unable to access a disk and the disk state is failed. Sun Feb 9 16:13:40 2025 Enclosure=2:Disk=3 EVT-STORAGE-00002: Unable to access a disk and the disk state is failed. ------------------------ ------------------ ------------------------------------------------------------------------ There are 3 active alerts.
Cause
The root cause of the issue is the failure of a process related to disk firmware upgrade, which results in the disks being marked as failed.
- The relevant script fails to receive a Resume request within 5 minutes of a Suspend request, causing the disks to be marked as failed.
Resolution
A fix for this issue has been identified and will be integrated into future versions of DDOS 8.3.x.
Until then, a Minimal Disruptive Upgrade (MDU) must be applied.
The MDU and relevant instructions can be found here (Dell Customer Login is required).
Note: Failed disk must NOT be replaced in this situation - these failures are addressed as part of the recovery actions and workaround.
Affected Products
DD OS 8.3, DD6400 ApplianceProducts
Data Domain, DD OS, PowerProtect DM5500Article Properties
Article Number: 000284599
Article Type: Solution
Last Modified: 02 May 2025
Version: 3
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