Dell Unity: SMB or NFS Shares may Become Inaccessible due to Blocked Threads
Summary: How to handle blocked thread events in a Dell Unity system. (Dell Correctable)
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The purpose of this article is to provide generic guidance on how to handle blocked thread events, as proper handling is crucial for Root Cause Analysis (RCA) and fix.
There are other articles available specific to certain Unity OE versions, such as article 000002643: DTA 503606: Unity: Arrays using CIFS/SMB running Operating Environment (OE) 4.2.0.9392909 or 4.2.0.9433914 should upgrade to OE 4.2.0.9476662 (or later), which addresses a potential data unavailability issue. (Only registered Dell Support users may be able to access this article.)
NAS servers, file system, and shares show online on the Dell Unity side, but blocked threads cause SMB or NFS shares to be unavailable to clients.
Possible error codes:
13:102d0003 neo-13:102d0003 neo-13:102d0007
Cause
Threads are resources used to process requests or actions. Various subsystems have their own allocated pools of threads.
There are different causes for blocked threads, and each case and system must be investigated separately.
Here are some of the most common reasons why these may occur:
There are different causes for blocked threads, and each case and system must be investigated separately.
Here are some of the most common reasons why these may occur:
- Deadlock where two threads are waiting for a resource lock owned by the other thread
- Extended operation processing (such as Delayed authentication, virus-checking, and so forth)
Resolution
To determine if you have blocked threads, look for the messages shown in the example below (notes section). If these messages are observed with timestamps that match the issue, the SP where they are being reported should be panicked or rebooted to restore access.
Immediate (temporary) solution:
A reboot or panic of the SP reporting the blocked threads messages restores access immediately. A reboot and a panic are essentially the same, the only difference is that the panic provides a memory dump file for post analysis.
Informational:
Multiple fixes are available to resolve this condition depending on the Unity OE version installed.
In cases where a fix does not exist, an SP panic is required as it allows Dell to get a dump file with the array's current condition for review. RCA may not be possible without this dump file. An SP panic requires root access.
Immediate (temporary) solution:
A reboot or panic of the SP reporting the blocked threads messages restores access immediately. A reboot and a panic are essentially the same, the only difference is that the panic provides a memory dump file for post analysis.
Informational:
- Although a simple reboot temporarily alleviates the issue, it likely removes the ability to RCA.
- Only an SP dump (panic) gathered while the condition is present allows Dell Engineering to fully investigate and RCA the particular cause of Blocked Threads.
- Only Dell can perform an SP panic. Contact Dell Technical Support or your Authorized Service Representative, and quote this Dell article ID.
- This is not a permanent fix and if the underlying cause of the blocked threads is not resolved, this may happen again until the fix is implemented.
Multiple fixes are available to resolve this condition depending on the Unity OE version installed.
In cases where a fix does not exist, an SP panic is required as it allows Dell to get a dump file with the array's current condition for review. RCA may not be possible without this dump file. An SP panic requires root access.
Additional Information
This is seen live on the system or in logs.
In the error messages, you see the affected SP (the SP that must be rebooted):
The
On the affected SP (the SP where the affected NAS server resides), go to
/EMC/backend/log_shared is only present (mounted) on the primary SP, you must be on the primary SP (live or logs) to access this location and these files.
In the error messages, you see the affected SP (the SP that must be rebooted):
service@spa~# zgrep -i blocked /EMC/backend/log_shared/EMCSystemLogFile* EMCSystemLogFile.log:"2017-07-26T18:12:55.428Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 423 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL EMCSystemLogFile.log:"2017-07-26T18:27:55.474Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 1323 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL EMCSystemLogFile.log:"2017-07-26T18:42:55.520Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 2222 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL
Note: These messages may not always be found in the logs above, so if nothing is found in the
EMCSystemLogFile logs, always check directly in the ktraces to be sure.
The
ktrace files can wrap quickly so these messages may not be present in the latest uncompressed file. The recommendation would be to check in all the c4_safe_ktrace files (found in /EMC/C4Core/log/).
On the affected SP (the SP where the affected NAS server resides), go to
/EMC/C4Core/log/ and run the command below (ensure that the word BLOCKED is in all uppercase letters). If unsure of what SP is affected, run this on both and the affected SP should show these messages:
service@spa~# zgrep -h BLOCKED c4_safe_ktrace* | sort ... 2017/09/20-07:46:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 33730 seconds: Server operations may be impacted 2017/09/20-08:01:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 34630 seconds: Server operations may be impacted 2017/09/20-08:16:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 35530 seconds: Server operations may be impacted 2017/09/20-08:31:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 36430 seconds: Server operations may be impacted 2017/09/20-08:46:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 37330 seconds: Server operations may be impacted 2017/09/20-09:01:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 38230 seconds: Server operations may be impacted 2017/09/20-09:16:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 39130 seconds: Server operations may be impacted 2017/09/20-09:31:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 40030 seconds: Server operations may be impacted
Affected Products
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity FamilyProducts
Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity HybridArticle Properties
Article Number: 000058575
Article Type: Solution
Last Modified: 12 ديسمبر 2025
Version: 6
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