PowerStore: Systeemhealthcheck kan meerdere fouten melden nadat CP opnieuw is opgestart PowerStoreOS 3.2 of 3.5

Summary: In dit artikel wordt uitgelegd hoe u na een CP-herstart (inclusief NDU) op een PowerStoreOS 3.2 of 3.5 systeem het volgende probleem kan optreden. - Het uitvoeren van een systeemhealthcheck kan leiden tot meerdere mislukte controles. - Replicatiesessies kunnen zich ook in een onderbroken systeemstatus bevinden. - Het is niet mogelijk om een extern systeem toe te voegen. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

- De systeemcontrole kan de volgende mislukte controles opleveren:
Pre-Upgrade Check              node_a     Failed     PUHC health check returned 3 failed checks.
Checking SFP Alerts                       Failed
Checking Active Imports                   Failed 
Checking Storage Migrations               Failed  
REST Configuration Service     node_a     Failed     Unable to perform health check due to communication error.


- Replicatiesessies kunnen een onderbroken status van het systeem hebben.
Alert 0x01302d03 Data transfer is paused for file system replication session
Alert 0x01700403 A replication session associated with resource VolumeABC123 is in System_Paused state because of error.

- Pogingen om een extern systeem toe te voegen kunnen onmiddellijk of na 60 seconden mislukken.

Cause

Dit probleem was het gevolg van een softwareprobleem sinds 3.2.
Er zijn meerdere certificaten, komt overeen met meerdere IP's die het cluster gebruikt.
Tijdens het opnieuw opstarten van de CP (kan gebeuren tijdens NDU omdat we CP opnieuw opstarten tijdens NDU, kan ook gebeuren tijdens handmatige CP-herstart of een andere CP-herstart terwijl de betreffende versie wordt uitgevoerd) is er een racevoorwaarde dat CP niet altijd alle juiste certificaten kan laden tijdens elke herstart.
Als gevolg hiervan kan communicatie die afhankelijk is van certificaten worden beïnvloed, waaronder bijvoorbeeld:

- Replicatiebeheerverbinding verbroken en replicatiesessies beïnvloed.
- Systeemstatuscontrole is mislukt.
- Kan geen extern systeem toevoegen om de replicatie te configureren.

Resolution

Tijdelijke oplossing:

- Tijdelijke oplossing voor PUHC-fout:
Start Control Path (CP) opnieuw en voer na vijf minuten een systeemhealthcheck uit.
svc_container_mgmt restart CP
OPMERKING: Als het probleem niet is opgelost door de CP opnieuw te starten, wacht u 15 minuten en start u de CP opnieuw.
Het opnieuw opstarten van CP (beheerservices) heeft geen invloed op de hosttoegang en zou slechts een kort verlies van toegang tot de PowerStore Manager-gebruikersinterface (UI) moeten veroorzaken.

 - Tijdelijke oplossing voor het probleem met de replicatiepauze:
1. Opnieuw starten CP opnieuw op het problematische apparaat.
2. Hervat de replication_session op de gebruikersinterface van de bronarray. Bekijk het resultaat.

- Tijdelijke oplossing voor het probleem "kan extern systeem niet toevoegen":

1. Start CP opnieuw op het problematische apparaat.
2. Probeer "add remote system" opnieuw in de gebruikersinterface van de bronarray. Bekijk het resultaat.

 

OPMERKING: Als het probleem niet is opgelost door de CP opnieuw te starten, wacht u 15 minuten en start u de CP opnieuw.
Het opnieuw opstarten van CP (beheerservices) heeft geen invloed op de hosttoegang en zou slechts een kort verlies van toegang tot de PowerStore Manager-gebruikersinterface (UI) moeten veroorzaken.

 

Oplossing:

De oplossing voor dit probleem is beschikbaar in PowerStoreOS 3.6.

Affected Products

PowerStore, PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T

Products

PowerStore 9200T
Article Properties
Article Number: 000216753
Article Type: Solution
Last Modified: 26 Feb 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.