PowerStore 9000T: NAS Container Memory Change Causes Node Restart After Upgrade to v4.0.0.x

Summary: During an upgrade from PowerStoreOS 3.5.x or 3.6.x to PowerStoreOS v4.0.1.0 , v4.0.1.1, or v4.1.x The internal NAS memory limit is not set properly. This may lead to an out of memory condition and consequent NAS container restarts. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The PowerStore cluster may experience unexpected node reboots.

In rare scenarios, both nodes may reboot simultaneously, resulting in temporary data unavailability.

This issue only affects:

  • PowerStore 9000T models configured in Unified mode.
    • All other models and block only systems are not affected.
  • Clusters that are upgraded from PowerStoreOS versions 3.5 or 3.6 to versions 4.0.1.0.  v4.0.1.1, or v4.1.0.x
    • Systems delivered with version 4.0 pre-installed are not affected.
    • Note: The configuration file is updated when upgrading from version 3.x to 4.x. Upgrades from version 4.0.x to 4.1.x do not result in changes to the configuration file.

Note: This issue is detected by the off_release_sdnas_memory_config Pre Upgrade Health Check (PUHC). For details on this PUHC, see KB# 000250803 PowerStore: Pre upgrade health check (PUHC) to detect an SDNAS memory configuration issue

Cause

This issue is a result of a rebalancing of memory allocation limits between NAS services and the underlying platform in PowerStore version 4.0.

A mismatch may be encountered between the platform's limit for the NAS container compare with what the NAS attempts to internally allocate. This may lead to the platform's memory limit being reached, and a restart of the NAS service is triggered to resolve it.

This limit can be reached repeatedly, causing multiple NAS service restarts, until the memory allocation limit for the NAS service is fixed.

Resolution

This issue was resolved in PowerStoreOS version 4.0.1.2 (or later).

Workaround

With earlier versions, contact Dell Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.

Affected Products

PowerStore, PowerStore 9000T
Article Properties
Article Number: 000230511
Article Type: Solution
Last Modified: 19 Jun 2025
Version:  10
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