Installing Dell Pair Drops and Reconnects any Bluetooth Devices that are Already Connected
Summary: The following article provides information about a Bluetooth connection issue that is seen while installing the Dell Pair Application onto your computer.
Symptoms
The Dell Pair install momentarily reconnects any existing Bluetooth connections
You may experience a connection issue with any connected Bluetooth devices while you are installing the Dell Pair application. Bluetooth devices such as headsets, or a keyboard/mouse reset for about one second (the connection is reestablished when the installation is completed).
What is Dell Pair?
Dell Pair is a software utility that now comes preinstalled on certain Dell platforms and supports pairing Dell Bluetooth peripheral devices. (Bluetooth devices such as your wireless mouse or keyboard.) If you have the Dell Pair setting enabled, the utility User Interface (UI) should automatically appear when the computer is within detection range to pair with a device over a Bluetooth network.
Supported Platforms:
| Supported family | Supported Model |
|---|---|
| XPS | 9315, 9320, 9520, 9720 |
| Latitude | 7320, 7330, 7420, 7430, 7520, 7530, 9330, 9430 |
| Precision | 5470, 5570, 5770, 7670, 7770 |
Supported Operating Systems:
- Windows 10 (Build version 10.0.19041 and newer.)
- Windows 11
Cause
The Dell Pair installation software comes packaged with a USB filter driver. The filter driver is installed as part of the Dell Pair installation. The filter driver installation requires existing Bluetooth connections to be dropped and reconnected.