PowerStore: PowerStore OS re-installation (node repair) failed when file name of package used was changed after download from the Dell Support Site
Summary: PowerStoreOS re-installation (node repair) fail when the PowerStoreOS package file name changed from the one posted in the Dell Support site.
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Symptoms
The following procedures may fail in case the file name of the PowerStoreOS package used changed from the one posted in the Dell Support site:
A similar issue may be seen when running the svc_factory_reset service script on the PowerStore appliance using a PowerStoreOS package that its file name changed from the one posted in the Dell Support site. In this case, svc_factory_reset will complete successfully, but the affected PowerStore appliance may be re-imaged to a lower than expected PowerStore OS version.
Note: A PowerStoreOS upgrade (NDU) is not affected by this issue. NDU will complete successfully even if the file name of the package used was changed from the one posted in the Dell Support site.
- PowerStoreOS re-installation on a PowerStore node (node repair)
- Internal M.2 boot module replacement (primary M.2)
Alert id : 6a095105-c213-4d8c-8d0d-976b5e6be69a
Error Code : 0x00400302
Severity : Critical
Timestamp (UTC): 2022-05-22 15:50:20+00
Appliance Name : TCADPowerStore-appliance-1
Resource Type : node
Resource Name : Description : Node B reimage (primary M.2) failed.
Error Code : 0x00400302
Severity : Critical
Timestamp (UTC): 2022-05-22 15:50:20+00
Appliance Name : TCADPowerStore-appliance-1
Resource Type : node
Resource Name : Description : Node B reimage (primary M.2) failed.
A similar issue may be seen when running the svc_factory_reset service script on the PowerStore appliance using a PowerStoreOS package that its file name changed from the one posted in the Dell Support site. In this case, svc_factory_reset will complete successfully, but the affected PowerStore appliance may be re-imaged to a lower than expected PowerStore OS version.
Note: A PowerStoreOS upgrade (NDU) is not affected by this issue. NDU will complete successfully even if the file name of the package used was changed from the one posted in the Dell Support site.
Cause
This issue will occur after the PowerStoreOS package used for the scenarios listed in the Symptoms section of this article will have its file name change as part of the download from the Dell Support site to a local machine (e.g. on a Windows local machine, a " (1)" suffix is automatically added to the package file name when attempting to download the package a second time).
Resolution
To avoid this issue, prior to downloading a PowerStoreOS package to a local machine, confirm that this package was not already downloaded to your local machine. If yes, delete the previously downloaded package and then re-download the package from the Dell Support site.
At this point, this PowerStoreOS package can be used to perform PowerStoreOS reinstallation (node repair), Internal M.2 boot module replacement (primary M.2), or for running the svc_factory_reset script on the PowerStore appliance.
Important: These three procedures must only be performed by PowerStore Technical Support.
At this point, this PowerStoreOS package can be used to perform PowerStoreOS reinstallation (node repair), Internal M.2 boot module replacement (primary M.2), or for running the svc_factory_reset script on the PowerStore appliance.
Important: These three procedures must only be performed by PowerStore Technical Support.
Affected Products
PowerStoreArticle Properties
Article Number: 000200844
Article Type: Solution
Last Modified: 13 Jun 2025
Version: 3
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