AppSync: Sudo user fails to install or update a Linux Plugin

Summary: AppSync: Sudo user fails to install or update a Linux Plugin

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Sudo user fails to install or update a Linux Plugin.

The directory structure on the Linux Plugin host is created, however the expected .rsp file that should exist in the default location of /opt/emc/appsync is not created.

The last message and error in the AppSync server log is:

date/time INFO [Thread-1081 (HornetQ-client-global-threads-432334325)] [com.emc.archway.service.sshservice.SshServiceBean] [ASServername] [] cat LinuxName.fully.qual.name.orgappsync.pub >> authorized_keys 

date/time ERROR [Thread-1081 (HornetQ-client-global-threads-432334325)] [com.emc.archway.service.sshservice.SshServiceBean] [ASServername] [] Failed to add authorized_keys entry 

Cause

The <sudouser>/.ssh/authorized_keys file was owned by root. The sudo user did not have permission to read or write to it.

Resolution

Confirm the sudo user has read and write permissions to <sudouser>/.ssh/authorized_keys.

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000055169
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  5
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