NetWorker: Die NMC-Anmeldung schlägt fehl mit "There is a probleming the server, server_hostname. Überprüfen Sie, ob der Server ausgeführt wird."
Summary: Beim Versuch, sich beim NetWorker Management Console (NMC)-Server anzumelden, wird die Fehlermeldung "There is a probleming the server, server_hostname. Please verify that the server is running". Erscheint ...
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Symptoms
- Nach dem Versuch, sich bei der NetWorker Management Console (NMC) anzumelden, wird die folgende Fehlermeldung angezeigt:
Es liegt ein Problem bei der Kontaktaufnahme mit dem Server vor, server_hostname. Please verify that the server is running".
Cause
Die Firewall des NMC-Servers lässt keine Incomming-Verbindungen zu den TCP-Ports 9000 und oder 9001 zu.
Port 9000 wird vom NMC-HTTP-Prozess verwendet, wenn eine Verbindung vom NMC-Client zum NMC-Server hergestellt wird.
Port 9001 wird für RPC-Aufrufe von der Java-Konsole an den NMC-Server verwendet.
Port 9000 wird vom NMC-HTTP-Prozess verwendet, wenn eine Verbindung vom NMC-Client zum NMC-Server hergestellt wird.
Port 9001 wird für RPC-Aufrufe von der Java-Konsole an den NMC-Server verwendet.
Resolution
1. Stellen Sie auf dem NMC-Server sicher, dass der NMC-Prozess ausgeführt wird und die Ports 9000 und 9001 Folgendes zuhören:
2, a. Überprüfen Sie, ob die Betriebssystemfirewall aktiviert ist.
2, b. Wenn die Firewall aktiviert ist, deaktivieren Sie sie vorübergehend und bestätigen Sie, dass Sie eine Verbindung zu den Ports 9000 und 9001 vom NMC-Client herstellen können:
3. Wenn die Betriebssystemfirewall aktiviert sein muss, konfigurieren Sie Firewallregeln, um die Ports 9000 und 9001 zu akzeptieren. Diese Ports sind im NetWorker-Sicherheitskonfigurationsleitfaden beschrieben, der verfügbar ist über: https://www.dell.com/support/home/product-support/product/networker/docs
Linux:
systemctl status gst
netstat -apno | grep "9000\|9001"
netstat -apno | grep "9000\|9001"
Windows:
Aufgabenliste | findstr gst
netstat -aof | findstr 9000
netstat -aof | findstr 9001
netstat -aof | findstr 9000
netstat -aof | findstr 9001
2, a. Überprüfen Sie, ob die Betriebssystemfirewall aktiviert ist.
Linux:
firewall-cmd --stat
Windows:
netsh advfirewall show allprofiles state
ODER
suchen Sie nach "Check firewall status" (Firewallstatus prüfen).
ODER
suchen Sie nach "Check firewall status" (Firewallstatus prüfen).
HINWEIS: Wenn die Betriebssystemfirewall bereits deaktiviert ist, wenden Sie sich an das Netzwerk-/Sicherheitsteam, um festzustellen, ob eine Netzwerkfirewall zwischen dem NMC-Client und NMC-Serversystemen vorhanden ist.
2, b. Wenn die Firewall aktiviert ist, deaktivieren Sie sie vorübergehend und bestätigen Sie, dass Sie eine Verbindung zu den Ports 9000 und 9001 vom NMC-Client herstellen können:
Linux:
curl -v NMC_servername:Port
Windows (PowerShell):
Test-NetConnection -ComputerName NMC_servername -port PORT
HINWEIS: Wenn auf dem System, das für den Zugriff auf nmC verwendet wird, NetWorker installiert ist, können Sie auch den Befehl nsrports verwenden, um die Auflösung und Portkonnektivität zu überprüfen: nsrports -t NMC_servername -p Port
HINWEIS: Informationen zur Konfiguration der Firewallregeln des Betriebssystems finden Sie in der Dokumentation des Anbieters des Betriebssystems, da dies je nach Distribution variieren kann. Wenn Unterstützung bei der Konfiguration von Firewallregeln erforderlich ist, wenden Sie sich an den Systemadministrator und die lokalen Netzwerk- oder Sicherheitsteams.
Article Properties
Article Number: 000203361
Article Type: Solution
Last Modified: 15 Sept 2022
Version: 1
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