PowerStore: Intermittent alert codes 0x00400601 and 0x00400602 for mount /cyc_node
Summary: Alerts are generated and clear within seconds occurring daily for the mount /cyc_node due to SupportAssist file growth sharing space with daily data collections.
Symptoms
PowerStore appliances connected to SupportAssist generate alert codes 0x00400601 or 0x00400602 identifying mount /cyc_node within the alert. Both alerts generate a dial-home case, however, the alerts appear to clear within seconds of generation.
These alerts should not be ignored. Running out of available space on the /cyc_node mount may cause one or more of the following:
- Unexpected node reboots
- Failure during upgrade
- Failure of SupportAssist
- Failure to generate data collect logs
Validating cyc_node used space:
- Connect to the service console over SSH - PowerStore: How to connect to the service console over SSH
- Run command
df -h /cyc_node
- Review the Use% column
- If cyc_node usage is greater than 30%, this issue applies
[SVC:service@ABC1234-B user]$ df -h /cyc_node Filesystem Size Used Avail Use% Mounted on /dev/md112 738M 459M 226M 67% /cyc_node
Cause
-
Common scenarios linked to this alert are as follows and are addressable with the
svc_partition_cleanup servicescript:- Article # 000198173 PowerStore: System Health Checks Detects Lack of Space in cyc_node
- Article # 000202707 PowerStore: Pre-Upgrade Health Check fails due to lack of space in /cyc_cfs
- Article # 000193605 PowerStore: Data Collection Fails, and the PowerStore Manager User Interface Reports Abnormal Information
- Article # 000324110 PowerStore Alerts: Root partition usage of node X has exceeded 91 percent on mount /.
- Article # 000202949 PowerStore: Dell SupportAssist database may fill up and lead /cyc_node/ (an internal partition) to be full, causing either NDU failure or Node reboot
- Article # 000223342 PowerStore: Intermittent alert codes 0x00400601 and 0x00400602 for mount /cyc_node
- Article # 000328471 PowerStore: Root Partition usage increasing rapidly
Resolution
The vast majority of causes leading to partition full conditions have been resolved in PowerStoreOS LTS-v4.1.x.
After resolving the current condition, update the PowerStore Appliance to PowerStoreOS LTS-v4.1.x or higher.
WORKAROUND:
Cycle the SupportAssist feature to clear out extraneous files on the /cyc_node mount.
- From the PowerStore UI, go to Settings > Support Connectivity > Connection Type
- Take note of the configuration displayed as the details must be reentered in a later step
- Click to Disabled
- Click Apply at the bottom of the page
- Once the job appears to have finished, refresh the UI page to verify the feature is disabled
- If it does show disabled after a refresh of the UI page, continue to step 2
- If it remains enabled after two attempts, contact Dell Technical Support or your Authorized Service Representative, and reference this article ID
- Wait 15 minutes
- Enable SupportAssist with the original configuration details captured earlier
- Once the job appears to have finished, refresh the UI page to verify the feature is enabled
- If the issues persist utilize the svc_partion_cleanup service script to investigate and clean up the root partitions.
- General Installation Instructions: KB# 000371058 PowerStore: How To Install svc_injectable service scripts (Log in as a registered Dell Support user may be required to view this article.)
- svc_partition_cleanup Procedure: KB#000214954 PowerStore: How to run the injectable service script svc_partition_cleanup to clean up the partitions /cyc_node, /cyc_var and /cyc_cfs (Log in as a registered Dell Support user may be required to view this article.)
If the issues persist or return, contact Technical Support for assistance.
Reference KB# 000223342 for expedited service.